summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index c3aa105..008e253 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -39,6 +39,8 @@ EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc
39 39
40PACKAGE_ARCH = "${MACHINE_ARCH}" 40PACKAGE_ARCH = "${MACHINE_ARCH}"
41 41
42UBOOT_LOCALVERSION = "${@d.getVar('SDK_VERSION', True).partition(' ')[0]}"
43
42USRC ?= "" 44USRC ?= ""
43S = '${@base_conditional("USRC", "", "${WORKDIR}/git", "${USRC}", d)}' 45S = '${@base_conditional("USRC", "", "${WORKDIR}/git", "${USRC}", d)}'
44 46
@@ -47,6 +49,12 @@ do_compile () {
47 unset CFLAGS 49 unset CFLAGS
48 unset CPPFLAGS 50 unset CPPFLAGS
49 51
52 if [ ! -e ${B}/.scmversion -a ! -e ${S}/.scmversion ]
53 then
54 echo ${UBOOT_LOCALVERSION} > ${B}/.scmversion
55 echo ${UBOOT_LOCALVERSION} > ${S}/.scmversion
56 fi
57
50 if [ "x${UBOOT_MACHINES}" = "x" ]; then 58 if [ "x${UBOOT_MACHINES}" = "x" ]; then
51 UBOOT_MACHINES=${UBOOT_MACHINE} 59 UBOOT_MACHINES=${UBOOT_MACHINE}
52 fi 60 fi