summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-06-20 14:36:49 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 10:58:50 +0800
commite3956ffbc217e468e26c9ce2e8932d3720fabca4 (patch)
treedc06e0a40beac83a61d2694697fe85740e3aa986
parent6f6500d2961f1a902203d55e05edfa66167dbc56 (diff)
downloadmeta-fsl-ppc-e3956ffbc217e468e26c9ce2e8932d3720fabca4.tar.gz
cryptodev: rename to cryptodev-qoriq
The QorIQ version of cryptodev needs to use another recipe name and have a common provider, which is than choosen for QorIQ-based machines. Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--conf/machine/include/qoriq.inc6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-linux_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-module_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-tests_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc (renamed from recipes-kernel/cryptodev/cryptodev_1.7.inc)11
5 files changed, 28 insertions, 7 deletions
diff --git a/conf/machine/include/qoriq.inc b/conf/machine/include/qoriq.inc
index f99f4e7..84b5abb 100644
--- a/conf/machine/include/qoriq.inc
+++ b/conf/machine/include/qoriq.inc
@@ -3,12 +3,12 @@
3PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq" 3PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq"
4PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-qoriq" 4PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-qoriq"
5PREFERRED_PROVIDER_u-boot ?= "u-boot-qoriq" 5PREFERRED_PROVIDER_u-boot ?= "u-boot-qoriq"
6PREFERRED_PROVIDER_cryptodev-linux = "cryptodev-qoriq-linux"
7PREFERRED_PROVIDER_cryptodev-module = "cryptodev-qoriq-module"
8PREFERRED_PROVIDER_cryptodev-tests = "cryptodev-qoriq-tests"
6 9
7PREFERRED_VERSION_qemu = "2.4.0+fsl" 10PREFERRED_VERSION_qemu = "2.4.0+fsl"
8PREFERRED_VERSION_openssl = "1.0.1i" 11PREFERRED_VERSION_openssl = "1.0.1i"
9PREFERRED_VERSION_cryptodev-linux = "1.7"
10PREFERRED_VERSION_cryptodev-module = "1.7"
11PREFERRED_VERSION_cryptodev-tests = "1.7"
12 12
13MACHINE_FEATURES = "keyboard pci ext2 ext3 serial" 13MACHINE_FEATURES = "keyboard pci ext2 ext3 serial"
14MACHINE_EXTRA_RRECOMMENDS += "udev-rules-qoriq kernel-modules" 14MACHINE_EXTRA_RRECOMMENDS += "udev-rules-qoriq kernel-modules"
diff --git a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb
index 92ccd71..58db505 100644
--- a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb
@@ -1,7 +1,9 @@
1require cryptodev_${PV}.inc 1require cryptodev-qoriq_${PV}.inc
2 2
3SUMMARY = "A /dev/crypto device driver header file" 3SUMMARY = "A /dev/crypto device driver header file"
4 4
5PROVIDES = "cryptodev-linux"
6
5do_compile[noexec] = "1" 7do_compile[noexec] = "1"
6 8
7# Just install cryptodev.h which is the only header file needed to be exported 9# Just install cryptodev.h which is the only header file needed to be exported
@@ -10,3 +12,5 @@ do_install() {
10} 12}
11 13
12ALLOW_EMPTY_${PN} = "1" 14ALLOW_EMPTY_${PN} = "1"
15
16COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-module_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb
index e6b1f27..383b482 100644
--- a/recipes-kernel/cryptodev/cryptodev-module_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb
@@ -1,10 +1,14 @@
1require cryptodev_${PV}.inc 1require cryptodev-qoriq_${PV}.inc
2 2
3SUMMARY = "A /dev/crypto device driver kernel module" 3SUMMARY = "A /dev/crypto device driver kernel module"
4 4
5PROVIDES = "cryptodev-module"
6
5inherit module qoriq_build_64bit_kernel 7inherit module qoriq_build_64bit_kernel
6 8
7# Header file provided by a separate package 9# Header file provided by a separate package
8DEPENDS += "cryptodev-linux" 10DEPENDS += "cryptodev-linux"
9 11
10EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' 12EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
13
14COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
index 128ccc9..a60ea98 100644
--- a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
@@ -1,8 +1,10 @@
1require cryptodev_${PV}.inc 1require cryptodev-qoriq_${PV}.inc
2 2
3SUMMARY = "A test suite for /dev/crypto device driver" 3SUMMARY = "A test suite for /dev/crypto device driver"
4DEPENDS = "openssl" 4DEPENDS = "openssl"
5 5
6PROVIDES = "cryptodev-tests"
7
6EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' 8EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
7 9
8do_compile() { 10do_compile() {
@@ -15,3 +17,5 @@ do_install() {
15 17
16FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug" 18FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
17FILES_${PN} = "${bindir}/tests_cryptodev/*" 19FILES_${PN} = "${bindir}/tests_cryptodev/*"
20
21COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev_1.7.inc b/recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc
index 2060ce3..e4700db 100644
--- a/recipes-kernel/cryptodev/cryptodev_1.7.inc
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc
@@ -6,6 +6,15 @@ RREPLACES_${PN} = "ocf-linux"
6LICENSE = "GPLv2" 6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8 8
9python() {
10 pkgs = d.getVar('PACKAGES', True).split()
11 for p in pkgs:
12 if 'cryptodev-qoriq' in p:
13 d.appendVar("RPROVIDES_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
14 d.appendVar("RCONFLICTS_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
15 d.appendVar("RREPLACES_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
16}
17
9SRC_URI = "http://download.gna.org/cryptodev-linux/cryptodev-linux-${PV}.tar.gz" 18SRC_URI = "http://download.gna.org/cryptodev-linux/cryptodev-linux-${PV}.tar.gz"
10SRC_URI[md5sum] = "0b63b3481cf2c90386b35f057481d36b" 19SRC_URI[md5sum] = "0b63b3481cf2c90386b35f057481d36b"
11SRC_URI[sha256sum] = "41880533b53de4d7b3f054e230f576988dafb8eed7bef5ebcf6422bb2e3a3b25" 20SRC_URI[sha256sum] = "41880533b53de4d7b3f054e230f576988dafb8eed7bef5ebcf6422bb2e3a3b25"
@@ -46,7 +55,7 @@ file://0024-fix-COMPAT_CIOCKEY-ioctl-command-number.patch \
46 55
47# NOTE: remove this patch and all traces of DISTRO_FEATURE c29x_pkc 56# NOTE: remove this patch and all traces of DISTRO_FEATURE c29x_pkc
48# if pkc-host does not need customized cryptodev patches anymore 57# if pkc-host does not need customized cryptodev patches anymore
49SRC_URI_append = "${@bb.utils.contains('DISTRO_FEATURES', 'c29x_pkc', ' file://0001-don-t-advertise-RSA-keygen.patch', '' ,d)}" 58SRC_URI_append = "${@bb.utils.contains('DISTRO_FEATURES', 'c29x_pkc', ' file://0001-don-t-advertise-RSA-keygen.patch', '', d)}"
50 59
51S = "${WORKDIR}/cryptodev-linux-${PV}" 60S = "${WORKDIR}/cryptodev-linux-${PV}"
52 61