summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb')
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
new file mode 100644
index 0000000..a60ea98
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
@@ -0,0 +1,21 @@
1require cryptodev-qoriq_${PV}.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4DEPENDS = "openssl"
5
6PROVIDES = "cryptodev-tests"
7
8EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
9
10do_compile() {
11 oe_runmake testprogs
12}
13
14do_install() {
15 oe_runmake install_tests
16}
17
18FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
19FILES_${PN} = "${bindir}/tests_cryptodev/*"
20
21COMPATIBLE_MACHINE = "(qoriq)"