summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <b40290@freescale.com>2012-09-14 14:08:56 +0800
committerMatthew McClintock <msm@freescale.com>2012-09-19 11:38:34 -0500
commit04e3d099fe9789e79b7a25c4addd36934b853e45 (patch)
tree19b5318f0bcd24b2f1489fb28f183e542c782813
parent8308c30b22e629425600fffdd9df185046bb67c5 (diff)
downloadmeta-fsl-ppc-04e3d099fe9789e79b7a25c4addd36934b853e45.tar.gz
udev: do not automount block devices for fslmachines
kernel can’t boot up with extend partition in HDD FILESEXTRAPATHS_prepend is the right variable to extend file search path, this is applied for fsl ppc targets Signed-off-by: Chunrong Guo <b40290@freescale.com> Signed-off-by: Zhenhua Luo <b19537@freescale.com>
-rw-r--r--recipes-append/udev/files/local.rules3
-rw-r--r--recipes-append/udev/udev_164.bbappend5
2 files changed, 5 insertions, 3 deletions
diff --git a/recipes-append/udev/files/local.rules b/recipes-append/udev/files/local.rules
index 9c134ef..43034b8 100644
--- a/recipes-append/udev/files/local.rules
+++ b/recipes-append/udev/files/local.rules
@@ -15,6 +15,8 @@
15 15
16KERNEL=="nbd*", GOTO="persistent_storage_end" 16KERNEL=="nbd*", GOTO="persistent_storage_end"
17 17
18SUBSYSTEM=="block", ENV{DEVTYPE}=="partition", GOTO="nomountblock"
19
18# Media automounting 20# Media automounting
19SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh" 21SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh"
20SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh" 22SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
@@ -37,3 +39,4 @@ SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1
37 39
38LABEL="persistent_storage_end" 40LABEL="persistent_storage_end"
39 41
42LABEL="nomountblock"
diff --git a/recipes-append/udev/udev_164.bbappend b/recipes-append/udev/udev_164.bbappend
index 17988f1..f15533b 100644
--- a/recipes-append/udev/udev_164.bbappend
+++ b/recipes-append/udev/udev_164.bbappend
@@ -1,4 +1,3 @@
1FILEXTRAPATHS_prepend_fsl := "${THISDIR}/files:" 1FILESEXTRAPATHS_prepend_fsl := "${THISDIR}/files:"
2
3PR_fsl .= "+${DISTRO}.0"
4 2
3PR_fsl .= "+${DISTRO}.1"