summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <b19537@freescale.com>2012-08-30 09:07:09 +0000
committerMatthew McClintock <msm@freescale.com>2012-09-19 11:15:29 -0500
commit8308c30b22e629425600fffdd9df185046bb67c5 (patch)
treef0095683b55954275fcaa070068e67251347564f
parented785145ba6817ad1d1fdb79bbdfae4bfdbf75e1 (diff)
downloadmeta-fsl-ppc-8308c30b22e629425600fffdd9df185046bb67c5.tar.gz
lio-utils: add lio-utils-4.0
Signed-off-by: Zhenhua Luo <b19537@freescale.com>
-rw-r--r--recipes-tools/lio-utils/lio-utils_4.0.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-tools/lio-utils/lio-utils_4.0.bb b/recipes-tools/lio-utils/lio-utils_4.0.bb
new file mode 100644
index 0000000..d461350
--- /dev/null
+++ b/recipes-tools/lio-utils/lio-utils_4.0.bb
@@ -0,0 +1,48 @@
1SUMMARY = "lio-utils"
2DESCRIPTION = "a simple low-level configuration tool set for the Target+iSCSI (LIO)"
3HOMEPAGE = "http://linux-iscsi.org/index.php/Lio-utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=c3ea231a32635cbb5debedf3e88aa3df"
6
7SRC_URI = "git://risingtidesystems.com/lio-utils.git;protocal=git"
8SRCREV = "lio-4.0"
9S = "${WORKDIR}/git"
10
11inherit distutils
12
13EXTRA_OEMAKE += "-C ${S}/tools PREFIX=${prefix} DESTDIR=${D}"
14
15# pass LDFLAGS to linker to avoid missing GNU_HASH QA errors
16TARGET_CC_ARCH += "${LDFLAGS}"
17do_compile() {
18 cd ${S}/tcm-py
19 distutils_do_compile
20
21 cd ${S}/lio-py
22 distutils_do_compile
23
24 if test -d ${S}/tools; then
25 oe_runmake
26 fi
27}
28
29do_install() {
30 cd ${S}/tcm-py
31 distutils_do_install
32
33 cd ${S}/lio-py
34 distutils_do_install
35
36 SITE_PACKAGES=${D}/${PYTHON_SITEPACKAGES_DIR}
37 [ ! -d ${D}/${sbindir} ] && install -d ${D}/${sbindir}
38 for var in tcm_node tcm_dump tcm_loop tcm_fabric lio_dump lio_node; do
39 chmod a+x ${SITE_PACKAGES}/${var}.py
40 [ ! -f ${D}/${sbindir}/${var} ] && ln -s ${PYTHON_SITEPACKAGES_DIR}/${var}.py ${D}/${sbindir}/${var}
41 done
42
43 if test -d ${S}/tools; then
44 oe_runmake install
45 fi
46}
47
48FILES_${PN} += "${sbindir}/*"