summaryrefslogtreecommitdiffstats
path: root/recipes-fsl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-fsl')
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
new file mode 100644
index 0000000..0afa9b4
--- /dev/null
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
@@ -0,0 +1,46 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2
3SUMMARY = "Freescale Manufacturing Tool requirements"
4LICENSE = "MIT"
5
6inherit packagegroup
7
8PACKAGES = " \
9 ${PN}-base \
10 ${PN}-mtd \
11 ${PN}-extfs \
12"
13
14# The essential packages for device bootup that may be set in the
15# machine configuration file.
16MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
17
18# Distro can override the following VIRTUAL-RUNTIME providers:
19VIRTUAL-RUNTIME_keymaps ?= "keymaps"
20
21RDEPENDS_${PN}-base = " \
22 bash \
23 imx-uuc \
24 util-linux \
25 coreutils \
26 dosfstools \
27 base-files \
28 base-passwd \
29 busybox \
30 ${@base_contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
31 ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
32"
33
34RDEPENDS_${PN}-mtd = " \
35 ${PN}-base \
36 imx-kobs \
37 mtd-utils \
38 mtd-utils-ubifs \
39"
40
41RDEPENDS_${PN}-extfs = " \
42 ${PN}-base \
43 e2fsprogs-mke2fs \
44"
45
46PACKAGE_ARCH = "${MACHINE_ARCH}"