summaryrefslogtreecommitdiffstats
path: root/recipes-fsl
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-01-17 14:19:28 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2014-03-03 18:19:42 -0300
commitd83668ad23a7d70edbdf961d5b5ec5cdc00e2107 (patch)
tree5bc72623eeb73da8f64038d635d89840656632b0 /recipes-fsl
parent8fdf5c3a80016f9fb2e0b688baf6cf64e58c42ef (diff)
downloadmeta-fsl-arm-d83668ad23a7d70edbdf961d5b5ec5cdc00e2107.tar.gz
packagegroup-fsl-mfgtool: Provide the required packages
This provides the set of packages needed for Manufactoring Tool initramfs images. Change-Id: I895934110d4ffcfdb9d283c7ea015223093a95d2 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-fsl')
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
new file mode 100644
index 0000000..0afa9b4
--- /dev/null
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
@@ -0,0 +1,46 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2
3SUMMARY = "Freescale Manufacturing Tool requirements"
4LICENSE = "MIT"
5
6inherit packagegroup
7
8PACKAGES = " \
9 ${PN}-base \
10 ${PN}-mtd \
11 ${PN}-extfs \
12"
13
14# The essential packages for device bootup that may be set in the
15# machine configuration file.
16MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
17
18# Distro can override the following VIRTUAL-RUNTIME providers:
19VIRTUAL-RUNTIME_keymaps ?= "keymaps"
20
21RDEPENDS_${PN}-base = " \
22 bash \
23 imx-uuc \
24 util-linux \
25 coreutils \
26 dosfstools \
27 base-files \
28 base-passwd \
29 busybox \
30 ${@base_contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
31 ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
32"
33
34RDEPENDS_${PN}-mtd = " \
35 ${PN}-base \
36 imx-kobs \
37 mtd-utils \
38 mtd-utils-ubifs \
39"
40
41RDEPENDS_${PN}-extfs = " \
42 ${PN}-base \
43 e2fsprogs-mke2fs \
44"
45
46PACKAGE_ARCH = "${MACHINE_ARCH}"