summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2014.07.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb b/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
index 1a1f76d..010d2cc 100644
--- a/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
@@ -8,11 +8,17 @@ DEPENDS += "change-file-endianess-native"
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"
9 9
10do_compile_append () { 10do_compile_append () {
11 case "${UBOOT_MACHINE}" in 11 if [ "x${UBOOT_CONFIG}" != "x" ]
12 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/u-boot.bin ${S}/u-boot.swap.bin 8 12 then
13 mv ${S}/u-boot.swap.bin ${S}/u-boot.bin;; 13 for config in ${UBOOT_MACHINE}; do
14 *sdcard*) mv ${S}/u-boot-with-spl-pbl.bin ${S}/u-boot.bin;; 14 case "${config}" in
15 esac 15 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot.bin ${S}/${config}/u-boot.swap.bin 8
16 mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};;
17 *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;;
18 esac
19 done
20 fi
21
16} 22}
17 23
18PACKAGES += "${PN}-images" 24PACKAGES += "${PN}-images"