summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2015-04-03 13:54:16 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-04-03 15:29:52 -0300
commitd60b315681b21af9b0e76603993c7d139626a77e (patch)
tree59759391210e408db1a96ded21bb51de5705baf9
parent51197a9c169c342a6d7840c0d687fa50ba52d83c (diff)
downloadmeta-fsl-arm-d60b315681b21af9b0e76603993c7d139626a77e.tar.gz
u-boot-ls1: fix multiple u-boot compile path changed.
*fix the following error: |couldn't open "/poky/build/tmp/work/ls1021aqds-poky-linux-gnueabi/u-boot-ls1/2014.07-r0/git/u-boot.bin": no such file or directory (From OE-Core rev: eca277b0af9e0e29022f81f54c17bf24aec02232) Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2014.07.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb b/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
index 1a1f76d..010d2cc 100644
--- a/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
@@ -8,11 +8,17 @@ DEPENDS += "change-file-endianess-native"
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"
9 9
10do_compile_append () { 10do_compile_append () {
11 case "${UBOOT_MACHINE}" in 11 if [ "x${UBOOT_CONFIG}" != "x" ]
12 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/u-boot.bin ${S}/u-boot.swap.bin 8 12 then
13 mv ${S}/u-boot.swap.bin ${S}/u-boot.bin;; 13 for config in ${UBOOT_MACHINE}; do
14 *sdcard*) mv ${S}/u-boot-with-spl-pbl.bin ${S}/u-boot.bin;; 14 case "${config}" in
15 esac 15 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot.bin ${S}/${config}/u-boot.swap.bin 8
16 mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};;
17 *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;;
18 esac
19 done
20 fi
21
16} 22}
17 23
18PACKAGES += "${PN}-images" 24PACKAGES += "${PN}-images"