diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-06-10 17:03:02 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-06-11 09:53:25 -0300 |
commit | 83b240e7d25177053a340900f15d17bddc559f2e (patch) | |
tree | febff9285c5e118ee4c2d186dab626e7f31b9fae /recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-query-of-CFLAGS-to-pkgconfig.patch | |
parent | a3a6ca336023d41400e130f0d21fa35e0f67a6ea (diff) | |
download | meta-fsl-arm-83b240e7d25177053a340900f15d17bddc559f2e.tar.gz |
Remove GStreamer 0.10 support
The GStreamer 0.10 support is dead upstream and is being moved away of
OE-Core so there is no much sense to keep supporting and testing it.
This removes support for i.MX23, i.MX28 and i.MX5 SoCs for video
decoding using through Freescale proprietary plugin and codecs.
The support for i.MX5 SoCs can now be used in with Linux kernel
mainline, with GStreamer 1.0, without the need of Freescale
proprietary codecs.
The patch removes all the metadata specific to the GStreamer 0.10
support so it allow for an easier identification of the changes and
code.
Change-Id: I02ae3a104d303037031f02f66866255540c6e678
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-query-of-CFLAGS-to-pkgconfig.patch')
-rw-r--r-- | recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-query-of-CFLAGS-to-pkgconfig.patch | 46 |
1 files changed, 0 insertions, 46 deletions
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-query-of-CFLAGS-to-pkgconfig.patch b/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-query-of-CFLAGS-to-pkgconfig.patch deleted file mode 100644 index 16a75fc..0000000 --- a/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-query-of-CFLAGS-to-pkgconfig.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | From 3312c9fbc80b7b7fe3e28b24c4b8955aa3d5bf18 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Mon, 27 Apr 2015 15:36:06 -0300 | ||
4 | Subject: [PATCH] configure.ac: Fix query of CFLAGS to pkgconfig | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | The pkgconfig queries cannot be appended without explicit spaces as | ||
8 | pkgconfig does not print trailing spaces by itself. | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
13 | --- | ||
14 | configure.ac | 14 +++++++------- | ||
15 | 1 file changed, 7 insertions(+), 7 deletions(-) | ||
16 | |||
17 | diff --git a/configure.ac b/configure.ac | ||
18 | index 86da399..276728f 100755 | ||
19 | --- a/configure.ac | ||
20 | +++ b/configure.ac | ||
21 | @@ -175,15 +175,15 @@ AC_CHECK_LIB(rt, clock_gettime) | ||
22 | AC_SUBST(RT_CFLAGS) | ||
23 | AC_SUBST(RT_LIBS) | ||
24 | |||
25 | -FSL_MM_CORE_CFLAGS=`$PKG_CONFIG --cflags libfslaudiocodec 2>/dev/null` | ||
26 | -FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslvideocodec 2>/dev/null` | ||
27 | -FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslparser 2>/dev/null` | ||
28 | -FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslvpuwrap 2>/dev/null` | ||
29 | +FSL_MM_CORE_CFLAGS="`$PKG_CONFIG --cflags libfslaudiocodec 2>/dev/null` \ | ||
30 | + `$PKG_CONFIG --cflags libfslvideocodec 2>/dev/null` \ | ||
31 | + `$PKG_CONFIG --cflags libfslparser 2>/dev/null` \ | ||
32 | + `$PKG_CONFIG --cflags libfslvpuwrap 2>/dev/null`" | ||
33 | AC_SUBST(FSL_MM_CORE_CFLAGS) | ||
34 | |||
35 | -FSL_MM_CORE_LIBS=`$PKG_CONFIG --libs libfslaudiocodec 2>/dev/null` | ||
36 | -FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslvideocodec 2>/dev/null` | ||
37 | -FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslparser 2>/dev/null` | ||
38 | +FSL_MM_CORE_LIBS="`$PKG_CONFIG --libs libfslaudiocodec 2>/dev/null` \ | ||
39 | + `$PKG_CONFIG --libs libfslvideocodec 2>/dev/null` \ | ||
40 | + `$PKG_CONFIG --libs libfslparser 2>/dev/null`" | ||
41 | AC_SUBST(FSL_MM_CORE_LIBS) | ||
42 | |||
43 | EXTRAPLATFORMCFLAGS="-DARM -D_GNUC_" | ||
44 | -- | ||
45 | 2.1.4 | ||
46 | |||