diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-06-10 17:03:02 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-06-11 09:53:25 -0300 |
commit | 83b240e7d25177053a340900f15d17bddc559f2e (patch) | |
tree | febff9285c5e118ee4c2d186dab626e7f31b9fae /recipes-multimedia/gstreamer/gst-fsl-plugin | |
parent | a3a6ca336023d41400e130f0d21fa35e0f67a6ea (diff) | |
download | meta-fsl-arm-83b240e7d25177053a340900f15d17bddc559f2e.tar.gz |
Remove GStreamer 0.10 support
The GStreamer 0.10 support is dead upstream and is being moved away of
OE-Core so there is no much sense to keep supporting and testing it.
This removes support for i.MX23, i.MX28 and i.MX5 SoCs for video
decoding using through Freescale proprietary plugin and codecs.
The support for i.MX5 SoCs can now be used in with Linux kernel
mainline, with GStreamer 1.0, without the need of Freescale
proprietary codecs.
The patch removes all the metadata specific to the GStreamer 0.10
support so it allow for an easier identification of the changes and
code.
Change-Id: I02ae3a104d303037031f02f66866255540c6e678
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/gstreamer/gst-fsl-plugin')
2 files changed, 0 insertions, 115 deletions
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin/Remove-use-of-obsolete-VIDIOC_DBG_G_CHIP_IDENT.patch b/recipes-multimedia/gstreamer/gst-fsl-plugin/Remove-use-of-obsolete-VIDIOC_DBG_G_CHIP_IDENT.patch deleted file mode 100644 index 5635275..0000000 --- a/recipes-multimedia/gstreamer/gst-fsl-plugin/Remove-use-of-obsolete-VIDIOC_DBG_G_CHIP_IDENT.patch +++ /dev/null | |||
@@ -1,69 +0,0 @@ | |||
1 | From ce90794a3458af0aed43b8570cf44cd87900185d Mon Sep 17 00:00:00 2001 | ||
2 | From: Gary Bisson <bisson.gary@gmail.com> | ||
3 | Date: Fri, 25 Jul 2014 16:44:53 -0700 | ||
4 | Subject: [PATCH] Remove use of obsolete VIDIOC_DBG_G_CHIP_IDENT | ||
5 | |||
6 | This ioctl should never be used in application as | ||
7 | stated in videodev2.h header. | ||
8 | Moreover, its use in this plugin was very limited. | ||
9 | |||
10 | Signed-off-by: Gary Bisson <bisson.gary@gmail.com> | ||
11 | --- | ||
12 | src/misc/tvsrc/src/mfw_gst_tvsrc.c | 8 -------- | ||
13 | src/misc/v4l_source/src/mfw_gst_v4lsrc.c | 7 ------- | ||
14 | 2 files changed, 15 deletions(-) | ||
15 | |||
16 | diff --git a/src/misc/tvsrc/src/mfw_gst_tvsrc.c b/src/misc/tvsrc/src/mfw_gst_tvsrc.c | ||
17 | index 67e0cd2..f495b6f 100755 | ||
18 | --- a/src/misc/tvsrc/src/mfw_gst_tvsrc.c | ||
19 | +++ b/src/misc/tvsrc/src/mfw_gst_tvsrc.c | ||
20 | @@ -450,7 +450,6 @@ mfw_gst_tvsrc_capture_setup (MFWGstTVSRC * v4l_src) | ||
21 | struct v4l2_format fmt; | ||
22 | struct v4l2_control ctrl; | ||
23 | struct v4l2_streamparm parm; | ||
24 | - struct v4l2_dbg_chip_ident chip; | ||
25 | gint fd_v4l = 0; | ||
26 | struct v4l2_mxc_offset off; | ||
27 | gint in_width = 0, in_height = 0; | ||
28 | @@ -461,13 +460,6 @@ mfw_gst_tvsrc_capture_setup (MFWGstTVSRC * v4l_src) | ||
29 | return 0; | ||
30 | } | ||
31 | |||
32 | - if (ioctl (fd_v4l, VIDIOC_DBG_G_CHIP_IDENT, &chip)) { | ||
33 | - g_print ("VIDIOC_DBG_G_CHIP_IDENT failed.\n"); | ||
34 | - } else | ||
35 | - g_print ("sensor chip is %s\n", chip.match.name); | ||
36 | - | ||
37 | - | ||
38 | - | ||
39 | if (ioctl (fd_v4l, VIDIOC_G_STD, &id) < 0) { | ||
40 | g_print ("VIDIOC_G_STD failed\n"); | ||
41 | close (fd_v4l); | ||
42 | diff --git a/src/misc/v4l_source/src/mfw_gst_v4lsrc.c b/src/misc/v4l_source/src/mfw_gst_v4lsrc.c | ||
43 | index 2c2e838..85e7ff0 100755 | ||
44 | --- a/src/misc/v4l_source/src/mfw_gst_v4lsrc.c | ||
45 | +++ b/src/misc/v4l_source/src/mfw_gst_v4lsrc.c | ||
46 | @@ -464,7 +464,6 @@ mfw_gst_v4lsrc_capture_setup (MFWGstV4LSrc * v4l_src) | ||
47 | struct v4l2_format fmt = {0}; | ||
48 | struct v4l2_control ctrl = {0}; | ||
49 | struct v4l2_streamparm parm = {0}; | ||
50 | - struct v4l2_dbg_chip_ident chip = {0}; | ||
51 | struct v4l2_frmsizeenum fszenum = {0}; | ||
52 | gint input; | ||
53 | gint fd_v4l = 0; | ||
54 | @@ -476,12 +475,6 @@ mfw_gst_v4lsrc_capture_setup (MFWGstV4LSrc * v4l_src) | ||
55 | return 0; | ||
56 | } | ||
57 | |||
58 | - if (ioctl (fd_v4l, VIDIOC_DBG_G_CHIP_IDENT, &chip)) { | ||
59 | - GST_ERROR ("VIDIOC_DBG_G_CHIP_IDENT failed."); | ||
60 | - } else | ||
61 | - GST_INFO ("sensor chip is %s", chip.match.name); | ||
62 | - | ||
63 | - | ||
64 | if (v4l_src->crop_pixel) { | ||
65 | in_width = v4l_src->capture_width - (2 * v4l_src->crop_pixel); | ||
66 | in_height = v4l_src->capture_height - (2 * v4l_src->crop_pixel); | ||
67 | -- | ||
68 | 2.0.1 | ||
69 | |||
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-query-of-CFLAGS-to-pkgconfig.patch b/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-query-of-CFLAGS-to-pkgconfig.patch deleted file mode 100644 index 16a75fc..0000000 --- a/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-query-of-CFLAGS-to-pkgconfig.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | From 3312c9fbc80b7b7fe3e28b24c4b8955aa3d5bf18 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Mon, 27 Apr 2015 15:36:06 -0300 | ||
4 | Subject: [PATCH] configure.ac: Fix query of CFLAGS to pkgconfig | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | The pkgconfig queries cannot be appended without explicit spaces as | ||
8 | pkgconfig does not print trailing spaces by itself. | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
13 | --- | ||
14 | configure.ac | 14 +++++++------- | ||
15 | 1 file changed, 7 insertions(+), 7 deletions(-) | ||
16 | |||
17 | diff --git a/configure.ac b/configure.ac | ||
18 | index 86da399..276728f 100755 | ||
19 | --- a/configure.ac | ||
20 | +++ b/configure.ac | ||
21 | @@ -175,15 +175,15 @@ AC_CHECK_LIB(rt, clock_gettime) | ||
22 | AC_SUBST(RT_CFLAGS) | ||
23 | AC_SUBST(RT_LIBS) | ||
24 | |||
25 | -FSL_MM_CORE_CFLAGS=`$PKG_CONFIG --cflags libfslaudiocodec 2>/dev/null` | ||
26 | -FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslvideocodec 2>/dev/null` | ||
27 | -FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslparser 2>/dev/null` | ||
28 | -FSL_MM_CORE_CFLAGS+=`$PKG_CONFIG --cflags libfslvpuwrap 2>/dev/null` | ||
29 | +FSL_MM_CORE_CFLAGS="`$PKG_CONFIG --cflags libfslaudiocodec 2>/dev/null` \ | ||
30 | + `$PKG_CONFIG --cflags libfslvideocodec 2>/dev/null` \ | ||
31 | + `$PKG_CONFIG --cflags libfslparser 2>/dev/null` \ | ||
32 | + `$PKG_CONFIG --cflags libfslvpuwrap 2>/dev/null`" | ||
33 | AC_SUBST(FSL_MM_CORE_CFLAGS) | ||
34 | |||
35 | -FSL_MM_CORE_LIBS=`$PKG_CONFIG --libs libfslaudiocodec 2>/dev/null` | ||
36 | -FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslvideocodec 2>/dev/null` | ||
37 | -FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslparser 2>/dev/null` | ||
38 | +FSL_MM_CORE_LIBS="`$PKG_CONFIG --libs libfslaudiocodec 2>/dev/null` \ | ||
39 | + `$PKG_CONFIG --libs libfslvideocodec 2>/dev/null` \ | ||
40 | + `$PKG_CONFIG --libs libfslparser 2>/dev/null`" | ||
41 | AC_SUBST(FSL_MM_CORE_LIBS) | ||
42 | |||
43 | EXTRAPLATFORMCFLAGS="-DARM -D_GNUC_" | ||
44 | -- | ||
45 | 2.1.4 | ||
46 | |||