summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-09-02 16:49:45 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-09-14 10:45:17 -0300
commit24396b28f0137464cd82b9a19f705c1db180ead2 (patch)
tree827a6611d2d9f999ee27a1c0c40967de5b098471 /recipes-graphics/wayland
parent6efaa8cbf7b2f6d316978cc48880c6e740c57598 (diff)
downloadmeta-fsl-arm-24396b28f0137464cd82b9a19f705c1db180ead2.tar.gz
Rework i.MX6 UltraLite support to not use other i.MX6 code
The i.MX6 UltraLite is very different from the other i.MX6 SoCs and the current BSP infrastructure needs to be reworked to allow for more granullar control of the features each SoC provide to control the changes to be applied for the SoC peripherals support. For now, it is not possible to express this clearly in the BSP so the current change is to revert some of the changes done for the i.MX6 UltraLite to be enabled and make sure that the boards using the SoC does not inherit the 'mx6' override. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend7
1 files changed, 1 insertions, 6 deletions
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index a254f07..a7496da 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -1,11 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3# only install patch for mx6 with a GPU 3SRC_URI_append_mx6 = " file://0001-MGS-840-Add-i.MX6-support-for-weston.patch"
4GPU_PATCH = "file://0001-MGS-840-Add-i.MX6-support-for-weston.patch"
5SRC_URI_append_mx6q = " ${GPU_PATCH}"
6SRC_URI_append_mx6dl = " ${GPU_PATCH}"
7SRC_URI_append_mx6sx = " ${GPU_PATCH}"
8SRC_URI_append_mx6sl = " ${GPU_PATCH}"
9 4
10PACKAGECONFIG_append_mx6q = " cairo-glesv2" 5PACKAGECONFIG_append_mx6q = " cairo-glesv2"
11PACKAGECONFIG_append_mx6dl = " cairo-glesv2" 6PACKAGECONFIG_append_mx6dl = " cairo-glesv2"