summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/imx6ulevk.conf2
-rw-r--r--recipes-graphics/directfb/directfb_%.bbappend13
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend20
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend21
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend7
5 files changed, 16 insertions, 47 deletions
diff --git a/conf/machine/imx6ulevk.conf b/conf/machine/imx6ulevk.conf
index 319d9f0..00423cb 100644
--- a/conf/machine/imx6ulevk.conf
+++ b/conf/machine/imx6ulevk.conf
@@ -9,7 +9,7 @@ include conf/machine/include/tune-cortexa7.inc
9 9
10MACHINE_FEATURES += " pci wifi bluetooth" 10MACHINE_FEATURES += " pci wifi bluetooth"
11 11
12SOC_FAMILY = "mx6:mx6ul" 12SOC_FAMILY = "mx6ul"
13 13
14KERNEL_DEVICETREE = "imx6ul-14x14-evk.dtb imx6ul-14x14-evk-csi.dtb" 14KERNEL_DEVICETREE = "imx6ul-14x14-evk.dtb imx6ul-14x14-evk-csi.dtb"
15 15
diff --git a/recipes-graphics/directfb/directfb_%.bbappend b/recipes-graphics/directfb/directfb_%.bbappend
index 20aa642..a95af53 100644
--- a/recipes-graphics/directfb/directfb_%.bbappend
+++ b/recipes-graphics/directfb/directfb_%.bbappend
@@ -1,12 +1,3 @@
1# i.MX6 has DirectFB acceleration support, so add it 1# i.MX6 has DirectFB acceleration support, so add it
2RDEPENDS_${PN}_append_mx6q = " libvivante-dfb-mx6" 2RDEPENDS_${PN}_append_mx6 = " libvivante-dfb-mx6"
3PACKAGE_ARCH_mx6q = "${MACHINE_ARCH}" 3PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}"
4
5RDEPENDS_${PN}_append_mx6dl = " libvivante-dfb-mx6"
6PACKAGE_ARCH_mx6dl = "${MACHINE_ARCH}"
7
8RDEPENDS_${PN}_append_mx6sx = " libvivante-dfb-mx6"
9PACKAGE_ARCH_mx6sx = "${MACHINE_ARCH}"
10
11RDEPENDS_${PN}_append_mx6sl = " libvivante-dfb-mx6"
12PACKAGE_ARCH_mx6sl = "${MACHINE_ARCH}"
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index cc245b2..1f070a4 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -1,24 +1,14 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3MESA-DEMO-PATCH = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ 3SRC_URI_append_mx6 = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \
4 file://fix-clear-build-break.patch \ 4 file://fix-clear-build-break.patch \
5 file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \ 5 file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \
6 file://Add-OpenVG-demos-to-support-wayland.patch" 6 file://Add-OpenVG-demos-to-support-wayland.patch"
7 7
8# only apply patches on mx6 that have a GPU 8PACKAGECONFIG_remove_mx6 = " \
9SRC_URI_append_mx6q = " ${MESA-DEMO-PATCH}" 9 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
10SRC_URI_append_mx6dl = " ${MESA-DEMO-PATCH}" 10 bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu', '', d), d)}"
11SRC_URI_append_mx6sx = " ${MESA-DEMO-PATCH}" 11PACKAGECONFIG_remove_mx6sl = "gles1 gles2"
12SRC_URI_append_mx6sl = " ${MESA-DEMO-PATCH}"
13
14REMOVE_GLU = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
15 bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu', '', d), d)}"
16
17# only remove GLU on mx6 thave have a GPU
18PACKAGECONFIG_remove_mx6q = "${REMOVE_GLU}"
19PACKAGECONFIG_remove_mx6dl = "${REMOVE_GLU}"
20PACKAGECONFIG_remove_mx6sx = "${REMOVE_GLU}"
21PACKAGECONFIG_remove_mx6sl = "gles1 gles2 ${REMOVE_GLU}"
22 12
23PACKAGECONFIG_append = "\ 13PACKAGECONFIG_append = "\
24 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ 14 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 66913e1..2536afd 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,19 +1,12 @@
1PACKAGECONFIG_remove_mx6q = "egl gles" 1PACKAGECONFIG_remove_mx6 = "egl gles"
2PACKAGECONFIG_remove_mx6dl = "egl gles"
3PACKAGECONFIG_remove_mx6sx = "egl gles"
4PACKAGECONFIG_remove_mx6sl = "egl gles"
5 2
6# i.MX6SL uses mesa software rendering 3PROVIDES_remove_mx6 = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl"
4PROVIDES_remove_mx6q = "virtual/libgl"
5PROVIDES_remove_mx6dl = "virtual/libgl"
6PROVIDES_remove_mx6sx = "virtual/libgl"
7 7
8PROVIDES_remove_mx6q = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl" 8USE_VIV_LIBGL = "yes"
9PROVIDES_remove_mx6dl = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl" 9USE_VIV_LIBGL_mx6sl = "no"
10PROVIDES_remove_mx6sx = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl"
11PROVIDES_remove_mx6sl = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl"
12
13USE_VIV_LIBGL = "no"
14USE_VIV_LIBGL_mx6q = "yes"
15USE_VIV_LIBGL_mx6dl = "yes"
16USE_VIV_LIBGL_mx6sx = "yes"
17 10
18# FIXME: mesa should support 'x11-no-tls' option 11# FIXME: mesa should support 'x11-no-tls' option
19python () { 12python () {
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index a254f07..a7496da 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -1,11 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3# only install patch for mx6 with a GPU 3SRC_URI_append_mx6 = " file://0001-MGS-840-Add-i.MX6-support-for-weston.patch"
4GPU_PATCH = "file://0001-MGS-840-Add-i.MX6-support-for-weston.patch"
5SRC_URI_append_mx6q = " ${GPU_PATCH}"
6SRC_URI_append_mx6dl = " ${GPU_PATCH}"
7SRC_URI_append_mx6sx = " ${GPU_PATCH}"
8SRC_URI_append_mx6sl = " ${GPU_PATCH}"
9 4
10PACKAGECONFIG_append_mx6q = " cairo-glesv2" 5PACKAGECONFIG_append_mx6q = " cairo-glesv2"
11PACKAGECONFIG_append_mx6dl = " cairo-glesv2" 6PACKAGECONFIG_append_mx6dl = " cairo-glesv2"