summaryrefslogtreecommitdiffstats
path: root/qt5-layer
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-09-13 22:36:21 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-09-14 10:33:40 -0300
commit6efaa8cbf7b2f6d316978cc48880c6e740c57598 (patch)
tree49d35542b4071649513c20287f5edec6ea11e18c /qt5-layer
parent1a5a1675bf6ddb85dcabe775e1c3d39d787f4b05 (diff)
downloadmeta-fsl-arm-6efaa8cbf7b2f6d316978cc48880c6e740c57598.tar.gz
qtbase: follow 5.5 platform configuration style
This one comes up when building for non-x11 / wayland. for further details see qtbase commit d04c3d2079e0df79592128a67e115ecb90b08454 Author: Laszlo Agocs <laszlo.agocs@theqtcompany.com> Date: Mon Mar 2 16:09:22 2015 +0100 eglfs: Pluginize RPi, iMX6 and Mali backends eglfs does not depend on the device makespecs anymore when it comes to these device integration backends (hooks). Instead, backends are autodetected by configure. The name of the preferred plugin is still set in the device makespecs. This is optional. When not set and there is more than one plugin present in the system, the environment variable QT_QPA_EGLFS_INTEGRATION will have to be set at runtime. In the absence of that, the order is undefined. Change-Id: Ie1ced2c9aa1beff2adb13b4fdea7c499cb5a6aab Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@theqtcompany.com> Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com> Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'qt5-layer')
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend4
1 files changed, 1 insertions, 3 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 6570702..f157c4d 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -22,16 +22,14 @@ do_configure_prepend_mx6() {
22 if test ${IS_MX6SL} -eq 0; then 22 if test ${IS_MX6SL} -eq 0; then
23 23
24 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF 24 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
25EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/qeglfshooks_imx6.cpp
26IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 25IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1
26EGLFS_DEVICE_INTEGRATION = eglfs_viv
27EOF 27EOF
28 else 28 else
29 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF 29 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
30IMX6_CFLAGS = -DLINUX=1 30IMX6_CFLAGS = -DLINUX=1
31EOF 31EOF
32 fi 32 fi
33 # copy the hook in the mkspecs directory OE is using
34 cp ${S}/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp ${S}/mkspecs/linux-oe-g++/
35 else 33 else
36 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF 34 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
37IMX6_CFLAGS = -DLINUX=1 35IMX6_CFLAGS = -DLINUX=1