summaryrefslogtreecommitdiffstats
path: root/qt5-layer
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-09-13 22:36:20 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-09-14 10:33:40 -0300
commit1a5a1675bf6ddb85dcabe775e1c3d39d787f4b05 (patch)
tree827934aaadddb44583fb262aa888161be88a13c1 /qt5-layer
parent6e2b8aaa7e60d88d949571e40d96684927b21bc4 (diff)
downloadmeta-fsl-arm-1a5a1675bf6ddb85dcabe775e1c3d39d787f4b05.tar.gz
qtbase: remove Force_egl_visual_ID_33.patch
It does not apply for Qt 5.5 anymore and mainline qtbase takes care for vivante specifics. See qtbase commit e7bd18f156e508969cc536c0f0b8e3c2c3c75c47 Author: Laszlo Agocs <laszlo.agocs@theqtcompany.com> Date: Wed Mar 18 11:03:39 2015 +0100 Fix EGL config - X visual matching for i.MX6 Task-number: QTBUG-44290 Change-Id: I06cbb169803aa8a06ea310651def1f3582194c8e Reviewed-by: Jørgen Lind <jorgen.lind@theqtcompany.com> Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'qt5-layer')
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch23
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend4
2 files changed, 0 insertions, 27 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch b/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch
deleted file mode 100644
index b0be292..0000000
--- a/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Workaround EGL initialization failure due visual mismatch
2
3Error:
4
5Warning: EGL suggested using X Visual ID 33 (RGB888) for EGL config 28 (RGB444), but this is incompatable
6Unable to find an X11 visual which matches EGL config 28
7Could not initialize EGL
8Aborted
9
10Upstream-Status: Inappropriate [workaround]
11
12Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
13
14diff -Naur qtbase-opensource-src-5.1.1_original/src/platformsupport/eglconvenience/qxlibeglintegration.cpp qtbase-opensource-src-5.1.1/src/platformsupport/eglconvenience/qxlibeglintegration.cpp
15--- qtbase-opensource-src-5.1.1_original/src/platformsupport/eglconvenience/qxlibeglintegration.cpp 2013-12-25 19:08:42.163895341 -0800
16+++ qtbase-opensource-src-5.1.1/src/platformsupport/eglconvenience/qxlibeglintegration.cpp 2013-12-25 19:09:37.207893799 -0800
17@@ -180,5 +180,5 @@
18 }
19
20 qWarning("Unable to find an X11 visual which matches EGL config %d", configId);
21- return (VisualID)0;
22+ return (VisualID)33;
23 }
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 2803d0a..6570702 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,9 +1,5 @@
1# Copyright (C) 2013 Eric Bénard - Eukréa Electromatique 1# Copyright (C) 2013 Eric Bénard - Eukréa Electromatique
2 2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
4
5SRC_URI += "file://Force_egl_visual_ID_33.patch"
6
7HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" 3HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}"
8 4
9IS_MX6SL = "0" 5IS_MX6SL = "0"