summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-09-06 11:59:55 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-09-08 11:00:57 -0300
commit9356268bfb444b74a88491fca7a9d268ed72b561 (patch)
tree6b4720c1f4e88fb28e8e0c39cad1985f47d871b0
parent139b12a8854dce8177bab2042eed08cce42adf31 (diff)
downloadmeta-fsl-arm-9356268bfb444b74a88491fca7a9d268ed72b561.tar.gz
qtbase: Enable support for i.MX SoCs with PXP
This enables the use of GLES2 backend for Software Rendering allowing SoCs without GPU support to use it. Up to now, this includes i.MX6UL and i.MX7D. Change-Id: I3011a84198d42744639121394423106fcfc738b3 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 3b99886..a693fb2 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -6,10 +6,12 @@ HAS_X11 = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 1, 0, d)}"
6IMXGPU_imxgpu3d = "3d" 6IMXGPU_imxgpu3d = "3d"
7IMXGPU_imxgpu2d = "2d" 7IMXGPU_imxgpu2d = "2d"
8 8
9PACKAGECONFIG_GL_imxpxp = "gles2"
9PACKAGECONFIG_GL_imxgpu3d = "gles2" 10PACKAGECONFIG_GL_imxgpu3d = "gles2"
10PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}" 11PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}"
11 12
12QT_CONFIG_FLAGS_APPEND = "" 13QT_CONFIG_FLAGS_APPEND = ""
14QT_CONFIG_FLAGS_APPEND_imxpxp = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
13QT_CONFIG_FLAGS_APPEND_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}" 15QT_CONFIG_FLAGS_APPEND_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}"
14QT_CONFIG_FLAGS_APPEND_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" 16QT_CONFIG_FLAGS_APPEND_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
15QT_CONFIG_FLAGS_append = " ${QT_CONFIG_FLAGS_APPEND}" 17QT_CONFIG_FLAGS_append = " ${QT_CONFIG_FLAGS_APPEND}"