summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-09-01 18:13:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-09-08 11:00:49 -0300
commit139b12a8854dce8177bab2042eed08cce42adf31 (patch)
tree27528e11a945c4e86dc7259415b4cf62299fc43d
parentc3c65086e1b0cbb2aceb42bff1a3723f68ae5318 (diff)
downloadmeta-fsl-arm-139b12a8854dce8177bab2042eed08cce42adf31.tar.gz
gstreamer1.0-plugins-imx: Change EGL platform preference order
The i.MX BSP now defaults for XWayland when both X11 and Wayland support is available, so we ought to use the Wayland backend for this case as well. Change-Id: Iab93cebea5cbd9796aaf9903e25be2686ce653c4 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.2.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.2.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.2.bb
index 3ac54f2..5462159 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.2.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.2.bb
@@ -24,11 +24,11 @@ inherit waf
24do_compile[depends] += "virtual/kernel:do_shared_workdir" 24do_compile[depends] += "virtual/kernel:do_shared_workdir"
25 25
26# configure the eglvivsink element to use the appropriate EGL platform code 26# configure the eglvivsink element to use the appropriate EGL platform code
27# X11 if x11 is present in DISTRO_FEATURES 27# Wayland if 'wayland' is present in DISTRO_FEATURES, if not,
28# Wayland if x11 is not present in DISTRO_FEATURES, but wayland is 28# X11 if x11 is present in DISTRO_FEATURES,
29# Framebuffer otherwise 29# Framebuffer otherwise
30EGLVIVSINK_PLATFORM = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \ 30EGLVIVSINK_PLATFORM = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \
31 bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ 31 bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
32 'fb', d),d)}" 32 'fb', d),d)}"
33 33
34EGL_PLATFORM_CONF = "--egl-platform=${EGLVIVSINK_PLATFORM}" 34EGL_PLATFORM_CONF = "--egl-platform=${EGLVIVSINK_PLATFORM}"