summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/broadcom-nvram-config
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/broadcom-nvram-config')
-rw-r--r--recipes-bsp/broadcom-nvram-config/broadcom-nvram-config.bb31
-rw-r--r--recipes-bsp/broadcom-nvram-config/files/LICENCE.broadcom_bcm43xx65
-rw-r--r--recipes-bsp/broadcom-nvram-config/files/nitrogen6x-lite/nvram.txt80
-rw-r--r--recipes-bsp/broadcom-nvram-config/files/wandboard/nvram.txt70
4 files changed, 246 insertions, 0 deletions
diff --git a/recipes-bsp/broadcom-nvram-config/broadcom-nvram-config.bb b/recipes-bsp/broadcom-nvram-config/broadcom-nvram-config.bb
new file mode 100644
index 0000000..501cc20
--- /dev/null
+++ b/recipes-bsp/broadcom-nvram-config/broadcom-nvram-config.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Nvram support for Broadcom wifi chips"
2SECTION = "kernel"
3
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://LICENCE.broadcom_bcm43xx;md5=3160c14df7228891b868060e1951dfbc"
6
7SRC_URI = " \
8 file://nvram.txt \
9 file://LICENCE.broadcom_bcm43xx \
10"
11
12S="${WORKDIR}"
13
14do_install() {
15 install -d ${D}/lib/firmware/brcm
16
17 cp -r ${WORKDIR}/nvram.txt \
18 ${D}/lib/firmware/brcm/brcmfmac-sdio.txt
19}
20
21FILES_${PN} = " \
22 /lib/firmware/brcm/brcmfmac-sdio.txt \
23"
24BROADCOM_FIRMWARE = "INVALID"
25BROADCOM_FIRMWARE_nitrogen6x-lite = "bcm4330"
26BROADCOM_FIRMWARE_wandboard-dual = "bcm4329"
27BROADCOM_FIRMWARE_wandboard-quad = "bcm4329"
28
29RDEPENDS_${PN} = "linux-firmware-${BROADCOM_FIRMWARE}"
30
31COMPATIBLE_MACHINE = "(nitrogen6x-lite|wandboard-dual|wandboard-quad)"
diff --git a/recipes-bsp/broadcom-nvram-config/files/LICENCE.broadcom_bcm43xx b/recipes-bsp/broadcom-nvram-config/files/LICENCE.broadcom_bcm43xx
new file mode 100644
index 0000000..ff26fdd
--- /dev/null
+++ b/recipes-bsp/broadcom-nvram-config/files/LICENCE.broadcom_bcm43xx
@@ -0,0 +1,65 @@
1SOFTWARE LICENSE AGREEMENT
2
3The accompanying software in binary code form (“Software”), is licensed to you,
4or, if you are accepting on behalf of an entity, the entity and its affiliates
5exercising rights hereunder (“Licensee”) subject to the terms of this software
6license agreement (“Agreement”), unless Licensee and Broadcom Corporation
7(“Broadcom”) execute a separate written software license agreement governing
8use of the Software. ANY USE, REPRODUCTION, OR DISTRIBUTION OF THE SOFTWARE
9CONSTITUTES LICENSEE’S ACCEPTANCE OF THIS AGREEMENT.
10
111. License. Subject to the terms and conditions of this Agreement,
12Broadcom hereby grants to Licensee a limited, non-exclusive, non-transferable,
13royalty-free license: (i) to use and integrate the Software with any other
14software; and (ii) to reproduce and distribute the Software complete,
15unmodified, and as provided by Broadcom, solely for use with Broadcom
16proprietary integrated circuit product(s) sold by Broadcom with which the
17Software was designed to be used, or their successors.
18
192. Restrictions. Licensee shall distribute Software with a copy of this
20Agreement. Licensee shall not remove, efface or obscure any copyright or
21trademark notices from the Software. Reproductions of the Broadcom copyright
22notice shall be included with each copy of the Software, except where such
23Software is embedded in a manner not readily accessible to the end user.
24Licensee shall not: (i) use, license, sell or otherwise distribute the Software
25except as provided in this Agreement; (ii) attempt to modify in any way,
26reverse engineer, decompile or disassemble any portion of the Software; or
27(iii) use the Software or other material in violation of any applicable law or
28regulation, including but not limited to any regulatory agency. This Agreement
29shall automatically terminate upon Licensee’s failure to comply with any of the
30terms of this Agreement. In such event, Licensee will destroy all copies of the
31Software and its component parts.
32
333. Ownership. The Software is licensed and not sold. Title to and
34ownership of the Software, including all intellectual property rights thereto,
35and any portion thereof remain with Broadcom or its licensors. Licensee hereby
36covenants that it will not assert any claim that the Software created by or for
37Broadcom infringe any intellectual property right owned or controlled by
38Licensee.
39
404. Disclaimer. THE SOFTWARE IS OFFERED “AS IS,” AND BROADCOM PROVIDES AND
41GRANTS AND LICENSEE RECEIVES NO SUPPORT AND NO WARRANTIES OF ANY KIND, EXPRESS
42OR IMPLIED, BY STATUTE, COMMUNICATION OR CONDUCT WITH LICENSEE, OR OTHERWISE.
43BROADCOM SPECIFICALLY DISCLAIMS ANY IMPLIED WARRANTIES OF MERCHANTABILITY,
44FITNESS FOR A SPECIFIC PURPOSE, OR NONINFRINGEMENT CONCERNING THE SOFTWARE OR
45ANY UPGRADES TO OR DOCUMENTATION FOR THE SOFTWARE. WITHOUT LIMITATION OF THE
46ABOVE, BROADCOM GRANTS NO WARRANTY THAT THE SOFTWARE IS ERROR-FREE OR WILL
47OPERATE WITHOUT INTERRUPTION, AND GRANTS NO WARRANTY REGARDING ITS USE OR THE
48RESULTS THEREFROM INCLUDING, WITHOUT LIMITATION, ITS CORRECTNESS, ACCURACY, OR
49RELIABILITY. TO THE MAXIMUM EXTENT PERMITTED BY LAW, IN NO EVENT SHALL BROADCOM
50OR ANY OF ITS LICENSORS HAVE ANY LIABILITY FOR ANY DIRECT, INDIRECT,
51INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES, HOWEVER CAUSED AND ON ANY THEORY
52OF LIABILITY, WHETHER FOR BREACH OF CONTRACT, TORT (INCLUDING NEGLIGENCE) OR
53OTHERWISE, ARISING OUT OF THIS AGREEMENT OR USE, REPRODUCTION, OR DISTRIBUTION
54OF THE SOFTWARE, INCLUDING BUT NOT LIMITED TO LOSS OF DATA AND LOSS OF PROFITS,
55EVEN IF SUCH PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THESE
56LIMITATIONS SHALL APPLY NOTWITHSTANDING ANY FAILURE OF ESSENTIAL PURPOSE OF ANY
57LIMITED REMEDY.
58
595. Export Laws. LICENSEE UNDERSTANDS AND AGREES THAT THE SOFTWARE IS
60SUBJECT TO UNITED STATES AND OTHER APPLICABLE EXPORT-RELATED LAWS AND
61REGULATIONS AND THAT LICENSEE MAY NOT EXPORT, RE-EXPORT OR TRANSFER THE
62SOFTWARE OR ANY DIRECT PRODUCT OF THE SOFTWARE EXCEPT AS PERMITTED UNDER THOSE
63LAWS. WITHOUT LIMITING THE FOREGOING, EXPORT, RE-EXPORT, OR TRANSFER OF THE
64SOFTWARE TO CUBA, IRAN, NORTH KOREA, SUDAN, AND SYRIA IS PROHIBITED.
65
diff --git a/recipes-bsp/broadcom-nvram-config/files/nitrogen6x-lite/nvram.txt b/recipes-bsp/broadcom-nvram-config/files/nitrogen6x-lite/nvram.txt
new file mode 100644
index 0000000..6183cca
--- /dev/null
+++ b/recipes-bsp/broadcom-nvram-config/files/nitrogen6x-lite/nvram.txt
@@ -0,0 +1,80 @@
1#
2# Board configuration for Boundary Devices Nitrogen6-Lite
3#
4manfid=0x2d0
5prodid=0x0547
6vendid=0x14e4
7devid=0x4360
8boardtype=0x05e1
9boardrev=0x1202
10boardflags=0x0080200
11nocrc=1
12xtalfreq=37400
13boardnum=22
14ag0=254
15aa2g=1
16ccode=ALL
17pa0itssit=0x20
18pa0b0=5367
19pa0b1=-633
20pa0b2=-158
21rssismf2g=0xa
22rssismc2g=0x3
23rssisav2g=0x7
24#rssi params for 5GHz
25rssismf5g=0x4
26rssismc5g=0x3
27rssisav5g=0x7
28#PA parameters for lower a-band
29pa1lob0=4378
30pa1lob1=-596
31pa1lob2=-180
32#PA parameters for midband
33pa1b0=4672
34pa1b1=-603
35pa1b2=-172
36#PA parameters for high band
37pa1hib0=4752
38pa1hib1=-609
39pa1hib2=-173
40rxpo5g=0
41maxp2ga0=76
42maxp5ga0=0x42
43maxp5gla0=0x42
44maxp5gha0=0x42
45# 2.4G Tx Power offsets
46cck2gpo=0x4444
47ofdm2gpo=0x66666666
48mcs2gpo0=0x8888
49mcs2gpo1=0x8888
50# 5G Tx Power offsets
51ofdm5gpo=0x44444444
52ofdm5glpo=0x44444444
53ofdm5ghpo=0x44444444
54mcs5gpo0=0x6666
55mcs5gpo1=0x6666
56mcs5glpo0=0x6666
57mcs5glpo1=0x6666
58mcs5ghpo0=0x6666
59mcs5ghpo1=0x46666
60sromrev=3
61# il0macaddr=00:90:4c:c5:12:38
62wl0id=0x431b
63cckPwrOffset=4
64swctrlmap_2g=0x44844484,0x42824282,0x40804484,0x18282,0x1ff
65triso5g=0
66swctrlmap_5g=0x00100010,0x20202020,0x20202020,0x14202,0x0f0
67rfreg033=0x19
68rfreg033_cck=0x1f
69dacrate2g=160
70dacrate5g=160
71txalpfbyp2g=1
72bphyscale=17
73cckPwrIdxCorr=-15
74pacalidx2g=50
75#pacalidx5g=20
76noise_cal_ref_2g=53
77noise_cal_po_2g=0
78noise_cal_ref_5g=52
79noise_cal_po_5g=5,0,0
80
diff --git a/recipes-bsp/broadcom-nvram-config/files/wandboard/nvram.txt b/recipes-bsp/broadcom-nvram-config/files/wandboard/nvram.txt
new file mode 100644
index 0000000..53e4bba
--- /dev/null
+++ b/recipes-bsp/broadcom-nvram-config/files/wandboard/nvram.txt
@@ -0,0 +1,70 @@
1# bcm4329 NVRAM file for Wandboard Dual
2# $Copyright (C) 2008 Broadcom Corporation$
3# $id$
4
5sromrev=3
6vendid=0x14e4
7devid=0x432f
8boardtype=0x53e
9
10boardrev=0x41
11
12#boardflags=0x1200
13boardflags=0x200
14
15# Specify the xtalfreq if it is otherthan 38.4MHz
16xtalfreq=37400
17
18aa2g=3
19aa5g=0
20
21ag0=255
22#tri2g=0x64
23
24# 11g paparams
25pa0b0=5542,5542,5542
26pa0b1=64244,64244,64244
27pa0b2=65202,65202,65202
28
29pa0itssit=62
30pa0maxpwr=74
31opo=0
32mcs2gpo0=0x6666
33mcs2gpo1=0x6666
34
35# 11g rssi params
36rssismf2g=0xa,0xa,0xa
37rssismc2g=0xb,0xb,0xb
38rssisav2g=0x3,0x3,0x3
39bxa2g=0
40
41# country code
42ccode=ALL
43cctl=0x0
44cckdigfilttype=0
45ofdmdigfilttype=1
46
47rxpo2g=0
48
49boardnum=1
50macaddr=00:90:4c:c5:00:34
51
52# xtal pu and pd time control variable
53# pu time is driver default (0x1501)
54#r13t=0x1501
55
56#######
57nocrc=1
58
59#for mfgc
60otpimagesize=182
61
62# sdio extra configs
63hwhdr=0x05ffff031030031003100000
64
65#This generates empty F1, F2 and F3 tuple chains, and may be used if the host SDIO stack does not require the standard tuples.
66#RAW1=80 02 fe ff
67
68#This includes the standard FUNCID and FUNCE tuples in the F1, F2, F3 and common CIS.
69RAW1=80 32 fe 21 02 0c 00 22 2a 01 01 00 00 c5 0 e6 00 00 00 00 00 40 00 00 ff ff 80 00 00 00 00 00 00 00 00 00 00 c8 00 00 00 00 00 00 00 00 00 00 00 00 00 ff 20 04 D0 2 29 43 21 02 0c 00 22 04 00 20 00 5A
70nvramver=4.218.214.0