summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/broadcom-nvram-config/broadcom-nvram-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/broadcom-nvram-config/broadcom-nvram-config.bb')
-rw-r--r--recipes-bsp/broadcom-nvram-config/broadcom-nvram-config.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/broadcom-nvram-config/broadcom-nvram-config.bb b/recipes-bsp/broadcom-nvram-config/broadcom-nvram-config.bb
new file mode 100644
index 0000000..501cc20
--- /dev/null
+++ b/recipes-bsp/broadcom-nvram-config/broadcom-nvram-config.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Nvram support for Broadcom wifi chips"
2SECTION = "kernel"
3
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://LICENCE.broadcom_bcm43xx;md5=3160c14df7228891b868060e1951dfbc"
6
7SRC_URI = " \
8 file://nvram.txt \
9 file://LICENCE.broadcom_bcm43xx \
10"
11
12S="${WORKDIR}"
13
14do_install() {
15 install -d ${D}/lib/firmware/brcm
16
17 cp -r ${WORKDIR}/nvram.txt \
18 ${D}/lib/firmware/brcm/brcmfmac-sdio.txt
19}
20
21FILES_${PN} = " \
22 /lib/firmware/brcm/brcmfmac-sdio.txt \
23"
24BROADCOM_FIRMWARE = "INVALID"
25BROADCOM_FIRMWARE_nitrogen6x-lite = "bcm4330"
26BROADCOM_FIRMWARE_wandboard-dual = "bcm4329"
27BROADCOM_FIRMWARE_wandboard-quad = "bcm4329"
28
29RDEPENDS_${PN} = "linux-firmware-${BROADCOM_FIRMWARE}"
30
31COMPATIBLE_MACHINE = "(nitrogen6x-lite|wandboard-dual|wandboard-quad)"