summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-fslc-lts-mfgtool_5.10.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc-mfgtool_5.12.bb2
-rw-r--r--recipes-kernel/linux/linux-imx-headers_5.10.bb4
-rw-r--r--recipes-kernel/linux/linux-imx-mfgtool_5.10.bb2
-rw-r--r--recipes-kernel/linux/linux-qoriq.inc20
5 files changed, 15 insertions, 15 deletions
diff --git a/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.10.bb b/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.10.bb
index 63527d13..95dd72fb 100644
--- a/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.10.bb
+++ b/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.10.bb
@@ -6,7 +6,7 @@ DESCRIPTION = "Linux Kernel provided and supported by the Freescale Community \
6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \ 6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \
7environment" 7environment"
8 8
9FILESEXTRAPATHS_prepend := "${THISDIR}/linux-fslc:" 9FILESEXTRAPATHS:prepend := "${THISDIR}/linux-fslc:"
10require linux-fslc-lts_${PV}.bb 10require linux-fslc-lts_${PV}.bb
11require linux-mfgtool.inc 11require linux-mfgtool.inc
12 12
diff --git a/recipes-kernel/linux/linux-fslc-mfgtool_5.12.bb b/recipes-kernel/linux/linux-fslc-mfgtool_5.12.bb
index c155ebb9..09d35c91 100644
--- a/recipes-kernel/linux/linux-fslc-mfgtool_5.12.bb
+++ b/recipes-kernel/linux/linux-fslc-mfgtool_5.12.bb
@@ -6,7 +6,7 @@ DESCRIPTION = "Linux Kernel provided and supported by the Freescale Community \
6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \ 6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \
7environment" 7environment"
8 8
9FILESEXTRAPATHS_prepend := "${THISDIR}/linux-fslc:" 9FILESEXTRAPATHS:prepend := "${THISDIR}/linux-fslc:"
10require linux-fslc_${PV}.bb 10require linux-fslc_${PV}.bb
11require linux-mfgtool.inc 11require linux-mfgtool.inc
12 12
diff --git a/recipes-kernel/linux/linux-imx-headers_5.10.bb b/recipes-kernel/linux/linux-imx-headers_5.10.bb
index c656fa55..c282fc62 100644
--- a/recipes-kernel/linux/linux-imx-headers_5.10.bb
+++ b/recipes-kernel/linux/linux-imx-headers_5.10.bb
@@ -65,7 +65,7 @@ do_install() {
65# Without this setting the RDEPENDS in other recipes fails to find this 65# Without this setting the RDEPENDS in other recipes fails to find this
66# package, therefore causing the -dev package also to be skipped effectively not 66# package, therefore causing the -dev package also to be skipped effectively not
67# populating it into SDK 67# populating it into SDK
68ALLOW_EMPTY_${PN} = "1" 68ALLOW_EMPTY:${PN} = "1"
69 69
70INHIBIT_DEFAULT_DEPS = "1" 70INHIBIT_DEFAULT_DEPS = "1"
71DEPENDS += "unifdef-native bison-native rsync-native" 71DEPENDS += "unifdef-native bison-native rsync-native"
@@ -75,4 +75,4 @@ PACKAGE_ARCH = "${MACHINE_SOCARCH}"
75# Restrict this recipe to NXP BSP only, this recipe is not compatible 75# Restrict this recipe to NXP BSP only, this recipe is not compatible
76# with mainline BSP 76# with mainline BSP
77COMPATIBLE_HOST = '(null)' 77COMPATIBLE_HOST = '(null)'
78COMPATIBLE_HOST_use-nxp-bsp = '.*' 78COMPATIBLE_HOST:use-nxp-bsp = '.*'
diff --git a/recipes-kernel/linux/linux-imx-mfgtool_5.10.bb b/recipes-kernel/linux/linux-imx-mfgtool_5.10.bb
index 0a9f5259..311245b1 100644
--- a/recipes-kernel/linux/linux-imx-mfgtool_5.10.bb
+++ b/recipes-kernel/linux/linux-imx-mfgtool_5.10.bb
@@ -5,7 +5,7 @@ SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
5DESCRIPTION = "Linux Kernel provided and supported by Freescale that produces a \ 5DESCRIPTION = "Linux Kernel provided and supported by Freescale that produces a \
6Manufacturing Tool compatible Linux Kernel to be used in updater environment" 6Manufacturing Tool compatible Linux Kernel to be used in updater environment"
7 7
8FILESEXTRAPATHS_prepend := "${THISDIR}/linux-imx:" 8FILESEXTRAPATHS:prepend := "${THISDIR}/linux-imx:"
9require linux-imx_${PV}.bb 9require linux-imx_${PV}.bb
10require linux-mfgtool.inc 10require linux-mfgtool.inc
11 11
diff --git a/recipes-kernel/linux/linux-qoriq.inc b/recipes-kernel/linux/linux-qoriq.inc
index 4d134b47..edac1055 100644
--- a/recipes-kernel/linux/linux-qoriq.inc
+++ b/recipes-kernel/linux/linux-qoriq.inc
@@ -7,12 +7,12 @@ LICENSE = "GPLv2"
7 7
8S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
9 9
10DEPENDS_append = " libgcc" 10DEPENDS:append = " libgcc"
11# not put Images into /boot of rootfs, install kernel-image if needed 11# not put Images into /boot of rootfs, install kernel-image if needed
12RDEPENDS_${KERNEL_PACKAGE_NAME}-base = "" 12RDEPENDS:${KERNEL_PACKAGE_NAME}-base = ""
13 13
14KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" 14KERNEL_CC:append = " ${TOOLCHAIN_OPTIONS}"
15KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" 15KERNEL_LD:append = " ${TOOLCHAIN_OPTIONS}"
16KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" 16KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
17 17
18ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}" 18ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
@@ -24,9 +24,9 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
24SCMVERSION ?= "y" 24SCMVERSION ?= "y"
25LOCALVERSION = "" 25LOCALVERSION = ""
26DELTA_KERNEL_DEFCONFIG ?= "" 26DELTA_KERNEL_DEFCONFIG ?= ""
27DELTA_KERNEL_DEFCONFIG_prepend_qoriq-arm64 = "lsdk.config " 27DELTA_KERNEL_DEFCONFIG:prepend:qoriq-arm64 = "lsdk.config "
28DELTA_KERNEL_DEFCONFIG_prepend_fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config " 28DELTA_KERNEL_DEFCONFIG:prepend:fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config "
29DELTA_KERNEL_DEFCONFIG_prepend_ls102xa = "multi_v7_lpae.config lsdk.config " 29DELTA_KERNEL_DEFCONFIG:prepend:ls102xa = "multi_v7_lpae.config lsdk.config "
30 30
31do_merge_delta_config[depends] += "virtual/${TARGET_PREFIX}gcc:do_populate_sysroot bison-native:do_populate_sysroot" 31do_merge_delta_config[depends] += "virtual/${TARGET_PREFIX}gcc:do_populate_sysroot bison-native:do_populate_sysroot"
32do_merge_delta_config[dirs] = "${B}" 32do_merge_delta_config[dirs] = "${B}"
@@ -56,13 +56,13 @@ do_merge_delta_config() {
56addtask merge_delta_config before do_kernel_localversion after do_patch 56addtask merge_delta_config before do_kernel_localversion after do_patch
57 57
58# The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) 58# The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b)
59do_compile_prepend_fsl-lsch2-32b() { 59do_compile:prepend:fsl-lsch2-32b() {
60 ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale 60 ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
61} 61}
62 62
63do_install_prepend_fsl-lsch2-32b() { 63do_install:prepend:fsl-lsch2-32b() {
64 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale 64 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
65} 65}
66 66
67FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*" 67FILES:${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*"
68COMPATIBLE_MACHINE = "(qoriq)" 68COMPATIBLE_MACHINE = "(qoriq)"