summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/ceetm/ceetm_git.bb4
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ar_git.bb6
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ipc-multi_git.bb4
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ipc-single_git.bb4
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ipc.inc2
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb2
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb2
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc2
-rw-r--r--recipes-kernel/linux/linux-fslc-lts-mfgtool_5.10.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc-mfgtool_5.12.bb2
-rw-r--r--recipes-kernel/linux/linux-imx-headers_5.10.bb4
-rw-r--r--recipes-kernel/linux/linux-imx-mfgtool_5.10.bb2
-rw-r--r--recipes-kernel/linux/linux-qoriq.inc20
-rw-r--r--recipes-kernel/skmm-host/skmm-host_git.bb2
14 files changed, 29 insertions, 29 deletions
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb
index 2e92ad49..00790c8e 100644
--- a/recipes-kernel/ceetm/ceetm_git.bb
+++ b/recipes-kernel/ceetm/ceetm_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bac620b9883d38a84dfb73ca7122d915"
4 4
5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ceetm;nobranch=1" 5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ceetm;nobranch=1"
6SRCREV = "6a7f2ec2091df2f4380cb8d25a36c399aed5af1b" 6SRCREV = "6a7f2ec2091df2f4380cb8d25a36c399aed5af1b"
7SRC_URI_append = " file://0001-Makefile-update-CFLAGS.patch \ 7SRC_URI:append = " file://0001-Makefile-update-CFLAGS.patch \
8 file://0001-use-new-api-tc_print_rate.patch \ 8 file://0001-use-new-api-tc_print_rate.patch \
9" 9"
10DEPENDS = "iproute2" 10DEPENDS = "iproute2"
@@ -22,7 +22,7 @@ do_install(){
22 cp ${S}/q_ceetm.so ${D}/${libdir}/tc/ 22 cp ${S}/q_ceetm.so ${D}/${libdir}/tc/
23} 23}
24 24
25FILES_${PN} += "${libdir}/tc" 25FILES:${PN} += "${libdir}/tc"
26INHIBIT_PACKAGE_STRIP = "1" 26INHIBIT_PACKAGE_STRIP = "1"
27 27
28COMPATIBLE_MACHINE = "(qoriq)" 28COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-ar_git.bb b/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
index feddc8fa..f2cd1a57 100644
--- a/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
@@ -14,7 +14,7 @@ export KERNEL_PATH
14 14
15INHIBIT_PACKAGE_STRIP = "1" 15INHIBIT_PACKAGE_STRIP = "1"
16 16
17do_compile_prepend() { 17do_compile:prepend() {
18 sed -i -e 's,EXTRA_CFLAGS += -I$(PWD),EXTRA_CFLAGS += -I${S},' ${S}/armodule/source/Makefile 18 sed -i -e 's,EXTRA_CFLAGS += -I$(PWD),EXTRA_CFLAGS += -I${S},' ${S}/armodule/source/Makefile
19} 19}
20 20
@@ -25,8 +25,8 @@ do_install(){
25 cp -f ${S}/bin/ar_* ${D}${bindir}/ 25 cp -f ${S}/bin/ar_* ${D}${bindir}/
26} 26}
27 27
28FILES_${PN} += "${bindir}/" 28FILES:${PN} += "${bindir}/"
29INSANE_SKIP_${PN} = "ldflags" 29INSANE_SKIP:${PN} = "ldflags"
30COMPATIBLE_MACHINE = "(t1040|t1042)" 30COMPATIBLE_MACHINE = "(t1040|t1042)"
31 31
32CLEANBROKEN = "1" 32CLEANBROKEN = "1"
diff --git a/recipes-kernel/kernel-modules/kernel-module-ipc-multi_git.bb b/recipes-kernel/kernel-modules/kernel-module-ipc-multi_git.bb
index 74e01bd9..c2effd01 100644
--- a/recipes-kernel/kernel-modules/kernel-module-ipc-multi_git.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-ipc-multi_git.bb
@@ -7,7 +7,7 @@ do_install(){
7 install -m 755 ${S}/kernel/*.ko ${D}/usr/driver/IPC/multi_rat 7 install -m 755 ${S}/kernel/*.ko ${D}/usr/driver/IPC/multi_rat
8} 8}
9 9
10FILES_${PN} += "/usr/driver/IPC/multi_rat/*.ko" 10FILES:${PN} += "/usr/driver/IPC/multi_rat/*.ko"
11FILES_${PN}-dbg += "/usr/driver/IPC/multi_rat/.debug" 11FILES:${PN}-dbg += "/usr/driver/IPC/multi_rat/.debug"
12 12
13COMPATIBLE_MACHINE = "(b4860qds|b4420qds)" 13COMPATIBLE_MACHINE = "(b4860qds|b4420qds)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-ipc-single_git.bb b/recipes-kernel/kernel-modules/kernel-module-ipc-single_git.bb
index 86155423..23418175 100644
--- a/recipes-kernel/kernel-modules/kernel-module-ipc-single_git.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-ipc-single_git.bb
@@ -7,7 +7,7 @@ do_install(){
7 install -m 755 ${S}/kernel/*.ko ${D}/usr/driver/IPC/single_rat 7 install -m 755 ${S}/kernel/*.ko ${D}/usr/driver/IPC/single_rat
8} 8}
9 9
10FILES_${PN} += "/usr/driver/IPC/single_rat/*.ko" 10FILES:${PN} += "/usr/driver/IPC/single_rat/*.ko"
11FILES_${PN}-dbg += "/usr/driver/IPC/single_rat/.debug" 11FILES:${PN}-dbg += "/usr/driver/IPC/single_rat/.debug"
12 12
13COMPATIBLE_MACHINE = "(b4860qds|b4420qds)" 13COMPATIBLE_MACHINE = "(b4860qds|b4420qds)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-ipc.inc b/recipes-kernel/kernel-modules/kernel-module-ipc.inc
index 350ba186..903c53a4 100644
--- a/recipes-kernel/kernel-modules/kernel-module-ipc.inc
+++ b/recipes-kernel/kernel-modules/kernel-module-ipc.inc
@@ -11,7 +11,7 @@ SRCREV = "74d662707558290f070f9589177db730444bc435"
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13do_configure[depends] += "virtual/kernel:do_shared_workdir" 13do_configure[depends] += "virtual/kernel:do_shared_workdir"
14do_compile_prepend () { 14do_compile:prepend () {
15 cd ${S}/kernel 15 cd ${S}/kernel
16} 16}
17 17
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb b/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb
index f78a4c5b..40eadef3 100644
--- a/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb
@@ -11,4 +11,4 @@ EXTRA_OEMAKE += " \
11 CONFIG_WLAN_FEATURE_DSRC=y \ 11 CONFIG_WLAN_FEATURE_DSRC=y \
12" 12"
13 13
14RDEPENDS_${PN} += "firmware-qca6174" 14RDEPENDS:${PN} += "firmware-qca6174"
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb b/recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb
index fbc87ea2..92bc01fc 100644
--- a/recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb
@@ -14,4 +14,4 @@ EXTRA_OEMAKE += " \
14 SAP_AUTH_OFFLOAD=1 \ 14 SAP_AUTH_OFFLOAD=1 \
15" 15"
16 16
17RDEPENDS_${PN} += "firmware-qca9377" 17RDEPENDS:${PN} += "firmware-qca9377"
diff --git a/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc b/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc
index 0b23a47c..a7b8a4e6 100644
--- a/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc
+++ b/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc
@@ -20,4 +20,4 @@ EXTRA_OEMAKE += " \
20" 20"
21 21
22COMPATIBLE_MACHINE = "(imx)" 22COMPATIBLE_MACHINE = "(imx)"
23COMPATIBLE_HOST_libc-musl = 'null' 23COMPATIBLE_HOST:libc-musl = 'null'
diff --git a/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.10.bb b/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.10.bb
index 63527d13..95dd72fb 100644
--- a/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.10.bb
+++ b/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.10.bb
@@ -6,7 +6,7 @@ DESCRIPTION = "Linux Kernel provided and supported by the Freescale Community \
6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \ 6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \
7environment" 7environment"
8 8
9FILESEXTRAPATHS_prepend := "${THISDIR}/linux-fslc:" 9FILESEXTRAPATHS:prepend := "${THISDIR}/linux-fslc:"
10require linux-fslc-lts_${PV}.bb 10require linux-fslc-lts_${PV}.bb
11require linux-mfgtool.inc 11require linux-mfgtool.inc
12 12
diff --git a/recipes-kernel/linux/linux-fslc-mfgtool_5.12.bb b/recipes-kernel/linux/linux-fslc-mfgtool_5.12.bb
index c155ebb9..09d35c91 100644
--- a/recipes-kernel/linux/linux-fslc-mfgtool_5.12.bb
+++ b/recipes-kernel/linux/linux-fslc-mfgtool_5.12.bb
@@ -6,7 +6,7 @@ DESCRIPTION = "Linux Kernel provided and supported by the Freescale Community \
6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \ 6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \
7environment" 7environment"
8 8
9FILESEXTRAPATHS_prepend := "${THISDIR}/linux-fslc:" 9FILESEXTRAPATHS:prepend := "${THISDIR}/linux-fslc:"
10require linux-fslc_${PV}.bb 10require linux-fslc_${PV}.bb
11require linux-mfgtool.inc 11require linux-mfgtool.inc
12 12
diff --git a/recipes-kernel/linux/linux-imx-headers_5.10.bb b/recipes-kernel/linux/linux-imx-headers_5.10.bb
index c656fa55..c282fc62 100644
--- a/recipes-kernel/linux/linux-imx-headers_5.10.bb
+++ b/recipes-kernel/linux/linux-imx-headers_5.10.bb
@@ -65,7 +65,7 @@ do_install() {
65# Without this setting the RDEPENDS in other recipes fails to find this 65# Without this setting the RDEPENDS in other recipes fails to find this
66# package, therefore causing the -dev package also to be skipped effectively not 66# package, therefore causing the -dev package also to be skipped effectively not
67# populating it into SDK 67# populating it into SDK
68ALLOW_EMPTY_${PN} = "1" 68ALLOW_EMPTY:${PN} = "1"
69 69
70INHIBIT_DEFAULT_DEPS = "1" 70INHIBIT_DEFAULT_DEPS = "1"
71DEPENDS += "unifdef-native bison-native rsync-native" 71DEPENDS += "unifdef-native bison-native rsync-native"
@@ -75,4 +75,4 @@ PACKAGE_ARCH = "${MACHINE_SOCARCH}"
75# Restrict this recipe to NXP BSP only, this recipe is not compatible 75# Restrict this recipe to NXP BSP only, this recipe is not compatible
76# with mainline BSP 76# with mainline BSP
77COMPATIBLE_HOST = '(null)' 77COMPATIBLE_HOST = '(null)'
78COMPATIBLE_HOST_use-nxp-bsp = '.*' 78COMPATIBLE_HOST:use-nxp-bsp = '.*'
diff --git a/recipes-kernel/linux/linux-imx-mfgtool_5.10.bb b/recipes-kernel/linux/linux-imx-mfgtool_5.10.bb
index 0a9f5259..311245b1 100644
--- a/recipes-kernel/linux/linux-imx-mfgtool_5.10.bb
+++ b/recipes-kernel/linux/linux-imx-mfgtool_5.10.bb
@@ -5,7 +5,7 @@ SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
5DESCRIPTION = "Linux Kernel provided and supported by Freescale that produces a \ 5DESCRIPTION = "Linux Kernel provided and supported by Freescale that produces a \
6Manufacturing Tool compatible Linux Kernel to be used in updater environment" 6Manufacturing Tool compatible Linux Kernel to be used in updater environment"
7 7
8FILESEXTRAPATHS_prepend := "${THISDIR}/linux-imx:" 8FILESEXTRAPATHS:prepend := "${THISDIR}/linux-imx:"
9require linux-imx_${PV}.bb 9require linux-imx_${PV}.bb
10require linux-mfgtool.inc 10require linux-mfgtool.inc
11 11
diff --git a/recipes-kernel/linux/linux-qoriq.inc b/recipes-kernel/linux/linux-qoriq.inc
index 4d134b47..edac1055 100644
--- a/recipes-kernel/linux/linux-qoriq.inc
+++ b/recipes-kernel/linux/linux-qoriq.inc
@@ -7,12 +7,12 @@ LICENSE = "GPLv2"
7 7
8S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
9 9
10DEPENDS_append = " libgcc" 10DEPENDS:append = " libgcc"
11# not put Images into /boot of rootfs, install kernel-image if needed 11# not put Images into /boot of rootfs, install kernel-image if needed
12RDEPENDS_${KERNEL_PACKAGE_NAME}-base = "" 12RDEPENDS:${KERNEL_PACKAGE_NAME}-base = ""
13 13
14KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" 14KERNEL_CC:append = " ${TOOLCHAIN_OPTIONS}"
15KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" 15KERNEL_LD:append = " ${TOOLCHAIN_OPTIONS}"
16KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" 16KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
17 17
18ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}" 18ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
@@ -24,9 +24,9 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
24SCMVERSION ?= "y" 24SCMVERSION ?= "y"
25LOCALVERSION = "" 25LOCALVERSION = ""
26DELTA_KERNEL_DEFCONFIG ?= "" 26DELTA_KERNEL_DEFCONFIG ?= ""
27DELTA_KERNEL_DEFCONFIG_prepend_qoriq-arm64 = "lsdk.config " 27DELTA_KERNEL_DEFCONFIG:prepend:qoriq-arm64 = "lsdk.config "
28DELTA_KERNEL_DEFCONFIG_prepend_fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config " 28DELTA_KERNEL_DEFCONFIG:prepend:fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config "
29DELTA_KERNEL_DEFCONFIG_prepend_ls102xa = "multi_v7_lpae.config lsdk.config " 29DELTA_KERNEL_DEFCONFIG:prepend:ls102xa = "multi_v7_lpae.config lsdk.config "
30 30
31do_merge_delta_config[depends] += "virtual/${TARGET_PREFIX}gcc:do_populate_sysroot bison-native:do_populate_sysroot" 31do_merge_delta_config[depends] += "virtual/${TARGET_PREFIX}gcc:do_populate_sysroot bison-native:do_populate_sysroot"
32do_merge_delta_config[dirs] = "${B}" 32do_merge_delta_config[dirs] = "${B}"
@@ -56,13 +56,13 @@ do_merge_delta_config() {
56addtask merge_delta_config before do_kernel_localversion after do_patch 56addtask merge_delta_config before do_kernel_localversion after do_patch
57 57
58# The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) 58# The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b)
59do_compile_prepend_fsl-lsch2-32b() { 59do_compile:prepend:fsl-lsch2-32b() {
60 ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale 60 ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
61} 61}
62 62
63do_install_prepend_fsl-lsch2-32b() { 63do_install:prepend:fsl-lsch2-32b() {
64 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale 64 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
65} 65}
66 66
67FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*" 67FILES:${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*"
68COMPATIBLE_MACHINE = "(qoriq)" 68COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/skmm-host/skmm-host_git.bb b/recipes-kernel/skmm-host/skmm-host_git.bb
index 4b111b5d..6d4b4864 100644
--- a/recipes-kernel/skmm-host/skmm-host_git.bb
+++ b/recipes-kernel/skmm-host/skmm-host_git.bb
@@ -12,7 +12,7 @@ S = "${WORKDIR}/git"
12 12
13EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' 13EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
14 14
15FILES_${PN} += "/etc/skmm/ /usr/bin/" 15FILES:${PN} += "/etc/skmm/ /usr/bin/"
16 16
17COMPATIBLE_MACHINE = "(p4080ds|t4240qds)" 17COMPATIBLE_MACHINE = "(p4080ds|t4240qds)"
18PACKAGE_ARCH = "${MACHINE_ARCH}" 18PACKAGE_ARCH = "${MACHINE_ARCH}"