summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qoriq-cst
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/qoriq-cst')
-rw-r--r--recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch43
-rw-r--r--recipes-devtools/qoriq-cst/qoriq-cst_git.bb43
2 files changed, 86 insertions, 0 deletions
diff --git a/recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch b/recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch
new file mode 100644
index 00000000..d25675aa
--- /dev/null
+++ b/recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch
@@ -0,0 +1,43 @@
1From 81ec65e72f357fb2c395e40c5195434bbaddf7f7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 16 May 2020 08:21:52 -0700
4Subject: [PATCH] tools: Mark struct input_field file_field extern
5
6This struct is already defined in common/parse_utils.c
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 tools/header_generation/create_hdr_common.c | 2 +-
12 tools/pbi_creation/create_pbi_common.c | 2 +-
13 2 files changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/tools/header_generation/create_hdr_common.c b/tools/header_generation/create_hdr_common.c
16index bfa90a3..edf632c 100644
17--- a/tools/header_generation/create_hdr_common.c
18+++ b/tools/header_generation/create_hdr_common.c
19@@ -39,7 +39,7 @@
20 #include <crypto_utils.h>
21
22 extern struct g_data_t gd;
23-struct input_field file_field;
24+extern struct input_field file_field;
25
26 extern char line_data[];
27 static struct option long_options[] = {
28diff --git a/tools/pbi_creation/create_pbi_common.c b/tools/pbi_creation/create_pbi_common.c
29index ff2ed84..bd976da 100644
30--- a/tools/pbi_creation/create_pbi_common.c
31+++ b/tools/pbi_creation/create_pbi_common.c
32@@ -57,7 +57,7 @@ static char *parse_list[] = {
33
34 extern struct g_data_t gd;
35 extern char line_data[];
36-struct input_field file_field;
37+extern struct input_field file_field;
38
39 #define NUM_PARSE_LIST (sizeof(parse_list) / sizeof(char *))
40
41--
422.26.2
43
diff --git a/recipes-devtools/qoriq-cst/qoriq-cst_git.bb b/recipes-devtools/qoriq-cst/qoriq-cst_git.bb
new file mode 100644
index 00000000..ca0f35fb
--- /dev/null
+++ b/recipes-devtools/qoriq-cst/qoriq-cst_git.bb
@@ -0,0 +1,43 @@
1SUMMARY = "utility for security boot"
2SECTION = "cst"
3LICENSE = "BSD-3-Clause"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff"
6
7DEPENDS += "openssl qoriq-cst-native"
8RDEPENDS:${PN} = "bash"
9
10GENKEYS ?= "${STAGING_BINDIR_NATIVE}/cst/gen_keys"
11GENKEYS:class-native = "./gen_keys"
12
13inherit kernel-arch
14
15# specify the non default keys pair for secure boot if needed
16#SECURE_PRI_KEY = "/path/srk.pri"
17#SECURE_PUB_KEY = "/path/srk.pub"
18
19SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cst;nobranch=1 \
20 file://0001-tools-Mark-struct-input_field-file_field-extern.patch \
21"
22SRCREV = "dfe30d3f05cfe281896482839e57ed49c52f2088"
23
24S = "${WORKDIR}/git"
25
26EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
27CFLAGS:append = ' -Wno-deprecated-declarations'
28
29PARALLEL_MAKE = ""
30
31do_install () {
32 oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir}
33
34 if [ -n "${SECURE_PRI_KEY}" ]; then
35 cp -f ${SECURE_PRI_KEY} ${D}/${bindir}/cst/srk.pri
36 cp -f ${SECURE_PUB_KEY} ${D}/${bindir}/cst/srk.pub
37 elif [ ! -f ${D}/${bindir}/cst/srk.pri -o ! ${D}/${bindir}/cst/srk.pub ]; then
38 cd ${D}/${bindir}/cst && ${GENKEYS} 1024
39 fi
40}
41
42FILES:${PN}-dbg += "${bindir}/cst/.debug"
43BBCLASSEXTEND = "native nativesdk"