summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qoriq-cst/qoriq-cst_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/qoriq-cst/qoriq-cst_git.bb')
-rw-r--r--recipes-devtools/qoriq-cst/qoriq-cst_git.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-devtools/qoriq-cst/qoriq-cst_git.bb b/recipes-devtools/qoriq-cst/qoriq-cst_git.bb
new file mode 100644
index 00000000..ca0f35fb
--- /dev/null
+++ b/recipes-devtools/qoriq-cst/qoriq-cst_git.bb
@@ -0,0 +1,43 @@
1SUMMARY = "utility for security boot"
2SECTION = "cst"
3LICENSE = "BSD-3-Clause"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff"
6
7DEPENDS += "openssl qoriq-cst-native"
8RDEPENDS:${PN} = "bash"
9
10GENKEYS ?= "${STAGING_BINDIR_NATIVE}/cst/gen_keys"
11GENKEYS:class-native = "./gen_keys"
12
13inherit kernel-arch
14
15# specify the non default keys pair for secure boot if needed
16#SECURE_PRI_KEY = "/path/srk.pri"
17#SECURE_PUB_KEY = "/path/srk.pub"
18
19SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cst;nobranch=1 \
20 file://0001-tools-Mark-struct-input_field-file_field-extern.patch \
21"
22SRCREV = "dfe30d3f05cfe281896482839e57ed49c52f2088"
23
24S = "${WORKDIR}/git"
25
26EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
27CFLAGS:append = ' -Wno-deprecated-declarations'
28
29PARALLEL_MAKE = ""
30
31do_install () {
32 oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir}
33
34 if [ -n "${SECURE_PRI_KEY}" ]; then
35 cp -f ${SECURE_PRI_KEY} ${D}/${bindir}/cst/srk.pri
36 cp -f ${SECURE_PUB_KEY} ${D}/${bindir}/cst/srk.pub
37 elif [ ! -f ${D}/${bindir}/cst/srk.pri -o ! ${D}/${bindir}/cst/srk.pub ]; then
38 cd ${D}/${bindir}/cst && ${GENKEYS} 1024
39 fi
40}
41
42FILES:${PN}-dbg += "${bindir}/cst/.debug"
43BBCLASSEXTEND = "native nativesdk"