summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-imx_2019.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2019.04.bb19
1 files changed, 1 insertions, 18 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2019.04.bb b/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
index 9b12482d..4cfcb471 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
@@ -2,28 +2,11 @@
2# Copyright 2018 (C) O.S. Systems Software LTDA. 2# Copyright 2018 (C) O.S. Systems Software LTDA.
3# Copyright 2017-2019 NXP 3# Copyright 2017-2019 NXP
4 4
5DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards."
6require recipes-bsp/u-boot/u-boot.inc 5require recipes-bsp/u-boot/u-boot.inc
6require u-boot-imx-common.inc
7 7
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"
9 9
10LICENSE = "GPLv2+"
11LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13SRCBRANCH = "imx_v2019.04_4.19.35_1.1.0"
14SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}"
15SRCREV = "4d377539a1190e838eae5d8b8a794dde0696d572"
16
17DEPENDS += "flex-native bison-native bc-native dtc-native"
18
19S = "${WORKDIR}/git"
20
21inherit fsl-u-boot-localversion
22
23LOCALVERSION ?= "-${SRCBRANCH}"
24
25BOOT_TOOLS = "imx-boot-tools"
26
27do_deploy_append_mx8m() { 10do_deploy_append_mx8m() {
28 # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 11 # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
29 if [ -n "${UBOOT_CONFIG}" ] 12 if [ -n "${UBOOT_CONFIG}" ]