summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
diff options
context:
space:
mode:
authorJoshua Watt <Joshua.Watt@garmin.com>2020-03-25 09:09:06 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2020-03-30 11:26:32 -0300
commitdad59d2dd0bb42ca5a8c3c1c697c3576b76d334c (patch)
tree14a2ba079ca7ff23f5e01a24d797f152ab6e909e /recipes-bsp/u-boot/u-boot-imx_2019.04.bb
parentf75ec4ec1e25afc2f415e6cf25b96d2caf8f3936 (diff)
downloadmeta-freescale-dad59d2dd0bb42ca5a8c3c1c697c3576b76d334c.tar.gz
u-boot: Split out u-boot tools
Splits out the IMX u-boot tools build to it's own recipe. This is required because these are native tools and thus need to be in a -native recipe to be properly relocated (instead of being built as part of the target u-boot-imx recipe). If the tools aren't built in a -native recipe, then the mkimage tool will contain a hard coded path to the uninative program loader from the sandbox where it was first built and this will not get corrected when restored from sstate. The result is that the mkimage_uboot executable can't run because it's looking for a hard coded program loader that does not exist, resulting in strange build errors like: ./mkimage_uboot: Command not found even though the executable is obviously in the correct location. Signed-off-by: Joshua Watt <Joshua.Watt@garmin.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-imx_2019.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2019.04.bb19
1 files changed, 1 insertions, 18 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2019.04.bb b/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
index 9b12482d..4cfcb471 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
@@ -2,28 +2,11 @@
2# Copyright 2018 (C) O.S. Systems Software LTDA. 2# Copyright 2018 (C) O.S. Systems Software LTDA.
3# Copyright 2017-2019 NXP 3# Copyright 2017-2019 NXP
4 4
5DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards."
6require recipes-bsp/u-boot/u-boot.inc 5require recipes-bsp/u-boot/u-boot.inc
6require u-boot-imx-common.inc
7 7
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"
9 9
10LICENSE = "GPLv2+"
11LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13SRCBRANCH = "imx_v2019.04_4.19.35_1.1.0"
14SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}"
15SRCREV = "4d377539a1190e838eae5d8b8a794dde0696d572"
16
17DEPENDS += "flex-native bison-native bc-native dtc-native"
18
19S = "${WORKDIR}/git"
20
21inherit fsl-u-boot-localversion
22
23LOCALVERSION ?= "-${SRCBRANCH}"
24
25BOOT_TOOLS = "imx-boot-tools"
26
27do_deploy_append_mx8m() { 10do_deploy_append_mx8m() {
28 # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 11 # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
29 if [ -n "${UBOOT_CONFIG}" ] 12 if [ -n "${UBOOT_CONFIG}" ]