summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc_2023.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2023.01.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb b/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
new file mode 100644
index 00000000..1953d788
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
@@ -0,0 +1,25 @@
1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-fslc-common_${PV}.inc
3
4DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
5order to provide support for some backported features and fixes, or because it \
6was submitted for revision and it takes some time to become part of a stable \
7version, or because it is not applicable for upstreaming."
8
9inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
10
11DEPENDS += "bc-native dtc-native python3-setuptools-native"
12
13PROVIDES += "u-boot"
14
15B = "${WORKDIR}/build"
16
17# FIXME: Allow linking of 'tools' binaries with native libraries
18# used for generating the boot logo and other tools used
19# during the build process.
20EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
21 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
22 HOSTSTRIP=true'
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25COMPATIBLE_MACHINE = "(imx-generic-bsp)"