summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@foundries.io>2023-01-04 14:41:32 +0200
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2023-01-04 13:16:16 +0000
commit8518e03ea3013b40288c6c2887532ca6ddac92c4 (patch)
tree52bc1f16e6bf8073f2f4c35a7da2cbd4def769ad /recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
parent3a7f48e47d3aad8f23f0f689d907f284cfdb859d (diff)
downloadmeta-freescale-backport-1356-to-kirkstone.tar.gz
u-boot-fslc: upgrade to v2023.01+fslcbackport-1356-to-kirkstone
U-Boot fork has been updated to include new version v2023.01 from upstream. Following commits were ported from 2022.10+fslc revision: ---- - 598f87fbdb6 imx6qdl-sabresd: Pass mmc alias - 1b64b05f407 imx: iMX6: Define disconnect_from_pc function - 0335a01b6d5 MLK-21854-2 imx: uuu: Update autoboot to run uuu or fastboot - 9a38462d252 pico-imx6ul, pico-imx7d: Explain how to use eMMC user partition - 881d7241411 mx6sabre_common: Dynamically change the video output - e427569fa3e mx6sabresd: Enable video interfaces in bootargs ---- Update U-Boot recipe versions and point to new revision. Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@foundries.io> (cherry picked from commit 65a85cfc9da2ec8872e3b431db84acc6f6ca6da9)
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc_2023.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2023.01.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb b/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
new file mode 100644
index 00000000..1953d788
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
@@ -0,0 +1,25 @@
1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-fslc-common_${PV}.inc
3
4DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
5order to provide support for some backported features and fixes, or because it \
6was submitted for revision and it takes some time to become part of a stable \
7version, or because it is not applicable for upstreaming."
8
9inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
10
11DEPENDS += "bc-native dtc-native python3-setuptools-native"
12
13PROVIDES += "u-boot"
14
15B = "${WORKDIR}/build"
16
17# FIXME: Allow linking of 'tools' binaries with native libraries
18# used for generating the boot logo and other tools used
19# during the build process.
20EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
21 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
22 HOSTSTRIP=true'
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25COMPATIBLE_MACHINE = "(imx-generic-bsp)"