summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb
new file mode 100644
index 00000000..ed32a274
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.09.bb
@@ -0,0 +1,30 @@
1require u-boot-fslc-common_${PV}.inc
2
3DESCRIPTION = "U-boot bootloader mxsboot tool"
4SECTION = "bootloader"
5
6DEPENDS = "dtc openssl"
7
8PROVIDES = "u-boot-mxsboot"
9
10EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
11EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
12EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
13
14do_compile () {
15 oe_runmake sandbox_defconfig
16
17 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
18 # generating it requires bin2header tool, which for target build
19 # is built with target tools and thus cannot be executed on host.
20 sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
21
22 oe_runmake cross_tools NO_SDL=1
23}
24
25do_install () {
26 install -Dm 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
27 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
28}
29
30BBCLASSEXTEND = "native nativesdk"