summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb
new file mode 100644
index 00000000..abcb5013
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb
@@ -0,0 +1,45 @@
1require u-boot-fslc-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4DEPENDS = "mtd-utils"
5
6INSANE_SKIP_${PN} = "already-stripped"
7EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
8EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
9
10inherit uboot-config
11
12do_compile () {
13 oe_runmake ${UBOOT_MACHINE}
14 oe_runmake envtools
15}
16
17do_install () {
18 install -d ${D}${base_sbindir}
19 install -d ${D}${sysconfdir}
20 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
21 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
22
23 if [ -e ${WORKDIR}/fw_env.config ]; then
24 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
25 else
26 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
27 fi
28}
29
30do_install_class-cross () {
31 install -d ${D}${bindir_cross}
32 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
33 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
34}
35
36SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
37uboot_fw_utils_cross() {
38 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
39}
40
41PROVIDES += "u-boot-fw-utils"
42RPROVIDES_${PN} += "u-boot-fw-utils"
43
44PACKAGE_ARCH = "${MACHINE_ARCH}"
45BBCLASSEXTEND = "cross"