summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-09-15 11:00:05 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-09-15 11:00:05 -0300
commitd1e80b515e475c2b2aedbc73db7c361907fbc894 (patch)
tree518ff27b0bd62e48bb384c4e47eb5983f7e78c6f /recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb
parent501b840982a51311feef3efdfa548ca2efcf4a31 (diff)
downloadmeta-freescale-d1e80b515e475c2b2aedbc73db7c361907fbc894.tar.gz
u-boot-fslc: Upgrade to 2018.09-based fork
This updates the fork to current 2018.09 release and apply following changes on top: 62f2841dc4 pico-imx6ul: Add instructions for booting in Falcon mode a803c01c03 pico-imx6ul: Add Falcon mode support 3e5f58a2a4 wandboard: README: Include the mx6qp variant in the list 28b8458749 imx: imx6ull: fix pinmux input_val for uart5 rx pin 1bc802f9cc pico-imx6ul: Remove CONFIG_FSL_USDHC from .h cc97092f7c pico-imx6ul: Add new pico-hobbit config 11aaa94cd8 pico-imx6ul: Sync README with pico-imx7d 52723c960f pico-imx6ul: Improve default DFU settings c90fa9c1a2 pico-imx6ul: Add bootmenu to choose the baseboard 2141bc7952 pico-imx6ul: Sync defconfig with new changes 9ff1d5305d pico-imx6ul: Update the README file 2b0e81461c pico-imx6ul: Add support for the 512MB module e45ab0b309 pico-imx6ul: Add bmode support ad3c1b13d8 pico-imx6ul: Add fastboot support fa2c10bbac pico-imx6ul: Convert to SPL b143e3f027 pico-imx6ul: Convert to distro config a9c45f15b2 mx6sabre_common: Allow the videoargs to be passed to bootargs b584b845b1 mx25pdk: Change root to use a single partition layout 146e490814 mx6sabre_common: Dynamically change the video output a278950282 mx6sabresd: Enable video interfaces in bootargs 77cac8a16e mx6sabresd: Use LDO dtb file until LDO bypass support is added be4d1c4100 mx6slevk: Use LDO dtb file until LDO bypass support is added Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb
new file mode 100644
index 00000000..abcb5013
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.09.bb
@@ -0,0 +1,45 @@
1require u-boot-fslc-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4DEPENDS = "mtd-utils"
5
6INSANE_SKIP_${PN} = "already-stripped"
7EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
8EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
9
10inherit uboot-config
11
12do_compile () {
13 oe_runmake ${UBOOT_MACHINE}
14 oe_runmake envtools
15}
16
17do_install () {
18 install -d ${D}${base_sbindir}
19 install -d ${D}${sysconfdir}
20 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
21 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
22
23 if [ -e ${WORKDIR}/fw_env.config ]; then
24 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
25 else
26 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
27 fi
28}
29
30do_install_class-cross () {
31 install -d ${D}${bindir_cross}
32 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
33 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
34}
35
36SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
37uboot_fw_utils_cross() {
38 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
39}
40
41PROVIDES += "u-boot-fw-utils"
42RPROVIDES_${PN} += "u-boot-fw-utils"
43
44PACKAGE_ARCH = "${MACHINE_ARCH}"
45BBCLASSEXTEND = "cross"