summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-01-31 12:46:35 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-02-06 10:02:16 -0200
commit8f4114e3a73751841f3f4087248373a247c6d8ad (patch)
treea1e62a57ca24dc33eeaf2f5c3afb7aa90c378405 /recipes-virtualization
parent63bfc5a1a4bdfad1581e97400334ab006127b111 (diff)
downloadmeta-freescale-8f4114e3a73751841f3f4087248373a247c6d8ad.tar.gz
hypervisor: remove
This pkg will not be supported anymore. Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-virtualization')
-rw-r--r--recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch40
-rw-r--r--recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules2
-rw-r--r--recipes-virtualization/hypervisor/hypervisor_git.bb95
3 files changed, 0 insertions, 137 deletions
diff --git a/recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch b/recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch
deleted file mode 100644
index 1100ab6e..00000000
--- a/recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 51f545b9c16f6a371c129bd0fbb9c7f7ae339df3 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Thu, 13 Jul 2017 13:59:28 +0800
4Subject: [PATCH] fix build error gcc7
5
6
7Upstream-Status: Pending
8
9---
10 Makefile.build | 7 ++++---
11 1 file changed, 4 insertions(+), 3 deletions(-)
12
13diff --git a/Makefile.build b/Makefile.build
14index e93cc9a..f6028fe 100644
15--- a/Makefile.build
16+++ b/Makefile.build
17@@ -35,7 +35,8 @@ GENASSYM=$(libos)lib/genassym.sh
18
19 export libos := $(src)libos/
20
21-export CC=$(CROSS_COMPILE)gcc
22+
23+
24
25 export GCCINCDIR := $(shell $(CC) -print-file-name=include)
26 CC_OPTS=-Wa,-m$(CONFIG_GCC_CPU_FLAG) -nostdinc -I $(GCCINCDIR) -I $(GCCINCDIR)-fixed \
27@@ -46,8 +47,8 @@ CC_OPTS=-Wa,-m$(CONFIG_GCC_CPU_FLAG) -nostdinc -I $(GCCINCDIR) -I $(GCCINCDIR)-f
28 export CC_OPTS_NODEP := -include include/config/autoconf.h
29
30 export WARNINGS := -Wwrite-strings -Wmissing-prototypes \
31- -Wstrict-prototypes -Wold-style-definition \
32- -Wmissing-declarations
33+ -Wstrict-prototypes -Wold-style-definition -Wno-format-truncation \
34+ -Wmissing-declarations
35
36 # Our code should build without any of these warnings, but some
37 # external code may be excluded.
38--
392.7.4
40
diff --git a/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules b/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules
deleted file mode 100644
index 5edfa113..00000000
--- a/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules
+++ /dev/null
@@ -1,2 +0,0 @@
1# Add rule to handle setting up device node for FSL HV mgmt driver
2SUBSYSTEM=="misc", KERNEL=="fsl-hv", NAME="fsl-hv"
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb
deleted file mode 100644
index bf904e0a..00000000
--- a/recipes-virtualization/hypervisor/hypervisor_git.bb
+++ /dev/null
@@ -1,95 +0,0 @@
1DESCRIPTION = "Freescale embedded hypervisor"
2SECTION = "embedded-hv"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://README;endline=22;md5=0655bbc3b7d7166c30c87208b4e23cf0"
5
6PR = "r3"
7
8DEPENDS = "u-boot-mkimage-native"
9
10inherit deploy
11
12# TODO: fix dtc to use the already built package
13SRC_URI = " \
14 git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor;branch=sdk-v2.0.x \
15 git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig;branch=sdk-v2.0.x \
16 git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos;branch=sdk-v2.0.x \
17 git://git.kernel.org/pub/scm/utils/dtc/dtc.git;name=dtc;destsuffix=dtc \
18 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk;branch=sdk-v2.0.x \
19 file://81-fsl-embedded-hv.rules \
20 file://0001-fix-build-error-gcc7.patch \
21 "
22
23SRCREV_FORMAT="hypervisor"
24SRCREV = "f23ac6da140e1c7e6327093b18e4b6355075de79"
25SRCREV_kconfig = "a56025d4da992b856796b0eccac2e410d751dbac"
26SRCREV_libos = "64f4424c35b306a8103a68e23adea4274921d699"
27SRCREV_dtc = "a6d55e039fd22048687fe061b4609e2807efe764"
28SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533"
29
30S = "${WORKDIR}/git"
31
32OUTPUT ?= "output32"
33OUTPUT_powerpc64 = "output64"
34
35EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" HOSTCC="${BUILD_CC}" O="${OUTPUT}"'
36
37DEFCONFIG = "defconfig"
38DEFCONFIG_powerpc64 = "64bit_defconfig"
39
40COMPATIBLE_HOST_qoriq-ppc = ".*"
41COMPATIBLE_HOST ?= "(none)"
42
43inherit cml1
44do_configure () {
45 oe_runmake ${DEFCONFIG}
46}
47
48PKG_HV_HYPERTRK_SUPPORT = "n"
49do_compile () {
50 if [ "${PKG_HV_HYPERTRK_SUPPORT}" = "y" ]
51 then
52 oe_runmake silentoldconfig
53 export HV_DIR=$PWD
54 cd hypertrk
55 oe_runmake deploy
56 cd ..
57 fi
58
59 oe_runmake
60 oe_runmake partman
61}
62
63do_install () {
64 install -d ${D}/${bindir}
65 install ${B}/${OUTPUT}/bin/linux/partman ${D}/${bindir}/partman
66
67 install -d ${D}${sysconfdir}/udev/rules.d
68 install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d
69
70 install -d ${D}/boot/hv
71 install ${B}/${OUTPUT}/.config ${D}/boot/hv/hypervisor.config
72 install -m 644 ${B}/${OUTPUT}/bin/hv ${B}/${OUTPUT}/bin/hv.map \
73 ${B}/${OUTPUT}/bin/hv.uImage ${B}/${OUTPUT}/bin/hv.bin \
74 ${D}/boot/hv/
75}
76
77do_deploy () {
78 install -d ${DEPLOYDIR}/hv/
79 install ${B}/${OUTPUT}/.config ${DEPLOYDIR}/hv/hypervisor.config
80 install -m 644 ${B}/${OUTPUT}/bin/hv ${B}/${OUTPUT}/bin/hv.map \
81 ${B}/${OUTPUT}/bin/hv.uImage ${B}/${OUTPUT}/bin/hv.bin \
82 ${DEPLOYDIR}/hv/
83}
84addtask deploy before do_build after do_install
85
86do_deploy_append() {
87 rm -f ${B}/../hv
88}
89
90INSANE_SKIP_${PN} = 'already-stripped'
91INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
92ALLOW_EMPTY_${PN} = "1"
93PACKAGES_prepend = "${PN}-image ${PN}-partman "
94FILES_${PN}-image = "/boot/"
95FILES_${PN}-partman = "${bindir}/partman"