summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-01-31 12:46:34 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-02-06 10:02:16 -0200
commit63bfc5a1a4bdfad1581e97400334ab006127b111 (patch)
treed868d980be8c73e9c9d59812efc62f8047634e86 /recipes-virtualization
parentffd0cd5ef1a1101da4b271a9e08223b72e08884e (diff)
downloadmeta-freescale-63bfc5a1a4bdfad1581e97400334ab006127b111.tar.gz
hv-cfg: remove
This pkg will not be supported anymore. Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-virtualization')
-rw-r--r--recipes-virtualization/hv-cfg/hv-cfg_git.bb47
1 files changed, 0 insertions, 47 deletions
diff --git a/recipes-virtualization/hv-cfg/hv-cfg_git.bb b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
deleted file mode 100644
index 4f147d2d..00000000
--- a/recipes-virtualization/hv-cfg/hv-cfg_git.bb
+++ /dev/null
@@ -1,47 +0,0 @@
1DESCRIPTION = "Hypervisor Config"
2SECTION = "hv-cfg"
3LICENSE = "BSD"
4PR = "r6"
5
6LIC_FILES_CHKSUM = " \
7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
8 file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
9 file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
10 file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
11"
12
13DEPENDS += "dtc-native"
14
15# this package is specific to the machine itself
16INHIBIT_DEFAULT_DEPS = "1"
17PACKAGE_ARCH = "${MACHINE_ARCH}"
18
19inherit deploy
20
21SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git;branch=sdk-v2.0.x"
22SRCREV = "348748b2ce26258509997b19fead0dd7bba4dea4"
23
24S = "${WORKDIR}/git"
25
26HV_CFG_M ?= "${@d.getVar('MACHINE', True).replace('-64b','')}"
27HV_CFG_M_t1042 = "t1040rdb"
28
29do_install () {
30 make install
31
32 install -d ${D}/boot/hv-cfg
33 cp -r ${S}/${HV_CFG_M}/${HV_CFG_M}/* ${D}/boot/hv-cfg
34}
35
36do_deploy () {
37 install -d ${DEPLOYDIR}/hv-cfg
38 cp -r ${S}/${HV_CFG_M}/${HV_CFG_M}/* ${DEPLOYDIR}/hv-cfg
39}
40addtask deploy after do_install
41
42PACKAGES += "${PN}-image"
43FILES_${PN}-image += "/boot"
44
45COMPATIBLE_HOST_qoriq-ppc = ".*"
46COMPATIBLE_HOST ?= "(none)"
47ALLOW_EMPTY_${PN} = "1"