summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-02-21 13:04:46 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-02-24 13:32:53 -0600
commitf816e66fe29382d0f966740d616b32622bdcb69b (patch)
tree2cedcea9a94bdbad223b7fa883c0fd069d8bbc08 /recipes-security
parent9d374c6460a3f7b6286f795fc47ec578d2b68912 (diff)
downloadmeta-freescale-f816e66fe29382d0f966740d616b32622bdcb69b.tar.gz
optee-client: Fix incorrect packaging logic
- The logic for the tee-supplicant package doesn't work and the package ends up empty. In fact, tee-supplicant belongs in the main package anyway. - The main package already contains ${libdir}, so drop the redundant assignment. - The headers belong in the -dev package, so drop them from the main. - Drop the un-necessary INSANE_SKIP settings. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-client_3.15.0.imx.bb8
1 files changed, 0 insertions, 8 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.15.0.imx.bb b/recipes-security/optee-imx/optee-client_3.15.0.imx.bb
index 68c73727..6e8f1e54 100644
--- a/recipes-security/optee-imx/optee-client_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-client_3.15.0.imx.bb
@@ -47,12 +47,4 @@ do_install () {
47 install -D -p -m0644 ${WORKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/tee-supplicant.service 47 install -D -p -m0644 ${WORKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/tee-supplicant.service
48} 48}
49 49
50PACKAGES += "tee-supplicant"
51FILES:${PN} += "${libdir}/* ${includedir}/*"
52FILES:tee-supplicant += "${bindir}/tee-supplicant"
53
54INSANE_SKIP:${PN} = "ldflags dev-elf"
55INSANE_SKIP:${PN}-dev = "ldflags dev-elf"
56INSANE_SKIP:tee-supplicant = "ldflags"
57
58COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 50COMPATIBLE_MACHINE = "(imx-nxp-bsp)"