summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-02-16 12:40:17 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-02-24 13:32:53 -0600
commit9d374c6460a3f7b6286f795fc47ec578d2b68912 (patch)
tree297b0f3897be9bbf5d94362487ba672ee5dd3b5a /recipes-security
parentd38cf8527d87673d2df0b91dea690aee354aebaa (diff)
downloadmeta-freescale-9d374c6460a3f7b6286f795fc47ec578d2b68912.tar.gz
optee-*: For i.MX, require machine feature optee
The optee software should be enabled by the machine feature. If the machine feature is not there, but optee is built anyway, then something is wrong and the build should fail. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-client_3.15.0.imx.bb6
-rw-r--r--recipes-security/optee-imx/optee-os_3.15.0.imx.bb4
-rw-r--r--recipes-security/optee-imx/optee-test_3.15.0.imx.bb6
3 files changed, 11 insertions, 5 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.15.0.imx.bb b/recipes-security/optee-imx/optee-client_3.15.0.imx.bb
index dcfee307..68c73727 100644
--- a/recipes-security/optee-imx/optee-client_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-client_3.15.0.imx.bb
@@ -1,4 +1,4 @@
1# Copyright (C) 2017-2020 NXP 1# Copyright (C) 2017-2021 NXP
2 2
3SUMMARY = "OPTEE Client libs" 3SUMMARY = "OPTEE Client libs"
4HOMEPAGE = "http://www.optee.org/" 4HOMEPAGE = "http://www.optee.org/"
@@ -16,7 +16,9 @@ SRCREV = "182874320395787a389e5b0f7df02b32f3c0a1b0"
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17B = "${WORKDIR}/build" 17B = "${WORKDIR}/build"
18 18
19inherit python3native systemd 19inherit python3native systemd features_check
20
21REQUIRED_MACHINE_FEATURES = "optee"
20 22
21SYSTEMD_SERVICE:${PN} = "tee-supplicant.service" 23SYSTEMD_SERVICE:${PN} = "tee-supplicant.service"
22 24
diff --git a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
index 58b238a7..ffa3cc85 100644
--- a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
@@ -17,7 +17,9 @@ SRCREV = "c939619d64dea014ad1b8382356eee4d1cbfbb22"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20inherit deploy python3native autotools 20inherit deploy python3native autotools features_check
21
22REQUIRED_MACHINE_FEATURES = "optee"
21 23
22# The platform flavor corresponds to the Yocto machine without the leading 'i'. 24# The platform flavor corresponds to the Yocto machine without the leading 'i'.
23PLATFORM_FLAVOR = "${@d.getVar('MACHINE')[1:]}" 25PLATFORM_FLAVOR = "${@d.getVar('MACHINE')[1:]}"
diff --git a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
index 22194a39..fd6ef926 100644
--- a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
@@ -1,4 +1,4 @@
1# Copyright (C) 2017-2020 NXP 1# Copyright (C) 2017-2021 NXP
2 2
3SUMMARY = "OPTEE test" 3SUMMARY = "OPTEE test"
4HOMEPAGE = "http://www.optee.org/" 4HOMEPAGE = "http://www.optee.org/"
@@ -17,7 +17,9 @@ B = "${WORKDIR}/build"
17 17
18SRCREV = "4d81b964a72e89a62d04187b3f055d8346b383c9" 18SRCREV = "4d81b964a72e89a62d04187b3f055d8346b383c9"
19 19
20inherit python3native 20inherit python3native features_check
21
22REQUIRED_MACHINE_FEATURES = "optee"
21 23
22OPTEE_ARCH ?= "arm32" 24OPTEE_ARCH ?= "arm32"
23OPTEE_ARCH:armv7a = "arm32" 25OPTEE_ARCH:armv7a = "arm32"