summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-02-16 11:54:36 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-02-24 13:32:53 -0600
commit9e67b70994ac094d36b05050cf68552fa5396803 (patch)
tree8b75483a6ef31c8863f9b48067fc623dee6f3c57 /recipes-security
parent71e49a7aef4ed44f085de05f31fa3671a95b80f6 (diff)
downloadmeta-freescale-9e67b70994ac094d36b05050cf68552fa5396803.tar.gz
optee-test: Upgrade 3.10.0.imx -> 3.15.0.imx
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-test_3.15.0.imx.bb (renamed from recipes-security/optee-imx/optee-test_3.10.0.imx.bb)10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.10.0.imx.bb b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
index 53951787..7eb11a84 100644
--- a/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
@@ -8,14 +8,14 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=daa2bcccc666345ab8940aab1315a4fa"
8 8
9DEPENDS = "python3-pycryptodome-native python3-pycryptodomex-native optee-os optee-client openssl" 9DEPENDS = "python3-pycryptodome-native python3-pycryptodomex-native optee-os optee-client openssl"
10 10
11SRCBRANCH = "imx_5.4.70_2.3.0" 11SRCBRANCH = "lf-5.10.72_2.2.0"
12 12
13SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH}" 13SRC_URI = "git://source.codeaurora.org/external/imx/imx-optee-test.git;protocol=https;branch=${SRCBRANCH}"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16B = "${WORKDIR}/build" 16B = "${WORKDIR}/build"
17 17
18SRCREV = "0c998f42a3fb87b9f2929955cf4b0116cc515091" 18SRCREV = "4d81b964a72e89a62d04187b3f055d8346b383c9"
19 19
20inherit python3native 20inherit python3native
21 21
@@ -45,6 +45,7 @@ do_compile() {
45 # Top level makefile doesn't seem to handle parallel make gracefully 45 # Top level makefile doesn't seem to handle parallel make gracefully
46 oe_runmake xtest 46 oe_runmake xtest
47 oe_runmake ta 47 oe_runmake ta
48 oe_runmake test_plugin
48} 49}
49do_compile[cleandirs] = "${B}" 50do_compile[cleandirs] = "${B}"
50 51
@@ -56,8 +57,11 @@ do_install () {
56 find ${B}/ta -name '*.ta' | while read name; do 57 find ${B}/ta -name '*.ta' | while read name; do
57 install -m 444 $name ${D}${nonarch_base_libdir}/optee_armtz/ 58 install -m 444 $name ${D}${nonarch_base_libdir}/optee_armtz/
58 done 59 done
60
61 install -d ${D}${libdir}/tee-supplicant/plugins/
62 install ${B}/supp_plugin/*plugin ${D}${libdir}/tee-supplicant/plugins/
59} 63}
60 64
61FILES:${PN} += "${nonarch_base_libdir}/optee_armtz/" 65FILES:${PN} += "${nonarch_base_libdir}/optee_armtz/ ${libdir}/tee-supplicant/plugins/"
62 66
63COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 67COMPATIBLE_MACHINE = "(imx-nxp-bsp)"