summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-02-18 17:04:22 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-02-24 13:32:53 -0600
commit71e49a7aef4ed44f085de05f31fa3671a95b80f6 (patch)
tree7630699de6de69c172fc810ae482a6a185e2feb9 /recipes-security
parent767e567cfb0152311ee8ab90c817e37763fde303 (diff)
downloadmeta-freescale-71e49a7aef4ed44f085de05f31fa3671a95b80f6.tar.gz
optee-test: Cleanup install and FILES
- Use variables properly for the install and FILES - Simplify the FILES update with an append Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee-imx/optee-test_3.10.0.imx.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.10.0.imx.bb b/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
index 7039d0c4..53951787 100644
--- a/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
@@ -49,15 +49,15 @@ do_compile() {
49do_compile[cleandirs] = "${B}" 49do_compile[cleandirs] = "${B}"
50 50
51do_install () { 51do_install () {
52 install -d ${D}/usr/bin 52 install -d ${D}${bindir}
53 install ${B}/xtest/xtest ${D}/usr/bin/ 53 install ${B}/xtest/xtest ${D}${bindir}
54 54
55 install -d ${D}/lib/optee_armtz 55 install -d ${D}${nonarch_base_libdir}/optee_armtz
56 find ${B}/ta -name '*.ta' | while read name; do 56 find ${B}/ta -name '*.ta' | while read name; do
57 install -m 444 $name ${D}/lib/optee_armtz/ 57 install -m 444 $name ${D}${nonarch_base_libdir}/optee_armtz/
58 done 58 done
59} 59}
60 60
61FILES:${PN} = "/usr/bin/ /lib*/optee_armtz/" 61FILES:${PN} += "${nonarch_base_libdir}/optee_armtz/"
62 62
63COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 63COMPATIBLE_MACHINE = "(imx-nxp-bsp)"