diff options
author | André Draszik <andre.draszik@jci.com> | 2019-01-17 14:29:17 +0000 |
---|---|---|
committer | André Draszik <andre.draszik@jci.com> | 2019-01-17 14:29:17 +0000 |
commit | 74df05a7f0fd698cbbe65b9bf925f186891426ca (patch) | |
tree | 169665d86e12f2aa2d6df71a856c1893267972d7 /recipes-multimedia | |
parent | 9704df97f08cf5895e2f5bcfb33f1a53d10c7704 (diff) | |
download | meta-freescale-74df05a7f0fd698cbbe65b9bf925f186891426ca.tar.gz |
remove True option to getVar calls
getVar() has been defaulting to expanding by default for
a long time (2016), thus remove the True option from
getVar() calls with a regex search and replace.
Search & replace made using the following command:
sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \
-i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \
| cut -d':' -f1 \
| sort -u)
Signed-off-by: André Draszik <andre.draszik@jci.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/imx-codec/imx-codec_4.4.2.bb | 4 | ||||
-rw-r--r-- | recipes-multimedia/imx-parser/imx-parser_4.4.2.bb | 2 |
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb b/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb index 60a3717e..39860c86 100644 --- a/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb +++ b/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb | |||
@@ -43,7 +43,7 @@ python __set_insane_skip() { | |||
43 | # Ensure we have PACKAGES expanded | 43 | # Ensure we have PACKAGES expanded |
44 | bb.build.exec_func("read_subpackage_metadata", d) | 44 | bb.build.exec_func("read_subpackage_metadata", d) |
45 | 45 | ||
46 | for p in d.getVar('PACKAGES', True).split(): | 46 | for p in d.getVar('PACKAGES').split(): |
47 | # Even though we are packaging libraries those are plugins so we | 47 | # Even though we are packaging libraries those are plugins so we |
48 | # shouldn't rename the packages to follow its sonames. | 48 | # shouldn't rename the packages to follow its sonames. |
49 | d.setVar("DEBIAN_NOAUTONAME_%s" % p, "1") | 49 | d.setVar("DEBIAN_NOAUTONAME_%s" % p, "1") |
@@ -66,7 +66,7 @@ python __split_libfslcodec_plugins() { | |||
66 | output_pattern='imx-codec-%s', | 66 | output_pattern='imx-codec-%s', |
67 | description='Freescale i.MX Codec (%s)', | 67 | description='Freescale i.MX Codec (%s)', |
68 | extra_depends='') | 68 | extra_depends='') |
69 | pkgs = d.getVar('PACKAGES', True).split() | 69 | pkgs = d.getVar('PACKAGES').split() |
70 | for pkg in pkgs: | 70 | for pkg in pkgs: |
71 | meta = pkg[10:] | 71 | meta = pkg[10:] |
72 | if meta != '': | 72 | if meta != '': |
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb b/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb index 492ab893..ed1a13da 100644 --- a/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb +++ b/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb | |||
@@ -30,7 +30,7 @@ python __set_insane_skip() { | |||
30 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | 30 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have |
31 | # the source we cannot fix it. Disable the insane check for now. | 31 | # the source we cannot fix it. Disable the insane check for now. |
32 | # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those | 32 | # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those |
33 | for p in d.getVar('PACKAGES', True).split(): | 33 | for p in d.getVar('PACKAGES').split(): |
34 | d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so textrel") | 34 | d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so textrel") |
35 | } | 35 | } |
36 | 36 | ||