summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-17 14:29:17 +0000
committerAndré Draszik <andre.draszik@jci.com>2019-01-17 14:29:17 +0000
commit74df05a7f0fd698cbbe65b9bf925f186891426ca (patch)
tree169665d86e12f2aa2d6df71a856c1893267972d7
parent9704df97f08cf5895e2f5bcfb33f1a53d10c7704 (diff)
downloadmeta-freescale-74df05a7f0fd698cbbe65b9bf925f186891426ca.tar.gz
remove True option to getVar calls
getVar() has been defaulting to expanding by default for a long time (2016), thus remove the True option from getVar() calls with a regex search and replace. Search & replace made using the following command: sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \ -i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \ | cut -d':' -f1 \ | sort -u) Signed-off-by: André Draszik <andre.draszik@jci.com>
-rw-r--r--classes/fsl-dynamic-packagearch.bbclass28
-rw-r--r--classes/fsl-eula-unpack.bbclass8
-rw-r--r--classes/machine-overrides-extender.bbclass6
-rw-r--r--classes/qoriq_build_64bit_kernel.bbclass2
-rw-r--r--dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc2
-rw-r--r--recipes-bsp/qe-ucode/qe-ucode_git.bb6
-rw-r--r--recipes-bsp/rcw/rcw_git.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb6
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.1.0g.bb2
-rw-r--r--recipes-daemons/ptpd/ptpd-qoriq.bb2
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb2
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc4
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend2
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc2
-rw-r--r--recipes-multimedia/imx-codec/imx-codec_4.4.2.bb4
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.4.2.bb2
16 files changed, 40 insertions, 40 deletions
diff --git a/classes/fsl-dynamic-packagearch.bbclass b/classes/fsl-dynamic-packagearch.bbclass
index a7cc53fc..9fcf37be 100644
--- a/classes/fsl-dynamic-packagearch.bbclass
+++ b/classes/fsl-dynamic-packagearch.bbclass
@@ -26,22 +26,22 @@
26# Copyright 2013-2016 (C) O.S. Systems Software LTDA. 26# Copyright 2013-2016 (C) O.S. Systems Software LTDA.
27 27
28python __anonymous () { 28python __anonymous () {
29 machine_arch_filter = set((d.getVar("MACHINE_ARCH_FILTER", True) or "").split()) 29 machine_arch_filter = set((d.getVar("MACHINE_ARCH_FILTER") or "").split())
30 machine_socarch_filter = set((d.getVar("MACHINE_SOCARCH_FILTER", True) or "").split()) 30 machine_socarch_filter = set((d.getVar("MACHINE_SOCARCH_FILTER") or "").split())
31 if machine_socarch_filter or machine_arch_filter: 31 if machine_socarch_filter or machine_arch_filter:
32 provides = set((d.getVar("PROVIDES", True) or "").split()) 32 provides = set((d.getVar("PROVIDES") or "").split())
33 depends = set((d.getVar("DEPENDS", True) or "").split()) 33 depends = set((d.getVar("DEPENDS") or "").split())
34 PN = d.getVar("PN", True) 34 PN = d.getVar("PN")
35 35
36 package_arch = None 36 package_arch = None
37 if list(machine_arch_filter & (provides | depends)): 37 if list(machine_arch_filter & (provides | depends)):
38 package_arch = d.getVar("MACHINE_ARCH", True) 38 package_arch = d.getVar("MACHINE_ARCH")
39 elif list(machine_socarch_filter & (provides | depends)): 39 elif list(machine_socarch_filter & (provides | depends)):
40 package_arch = d.getVar("MACHINE_SOCARCH", True) 40 package_arch = d.getVar("MACHINE_SOCARCH")
41 if not package_arch: 41 if not package_arch:
42 raise bb.parse.SkipPackage("You must set MACHINE_SOCARCH as MACHINE_SOCARCH_FILTER is set for this SoC.") 42 raise bb.parse.SkipPackage("You must set MACHINE_SOCARCH as MACHINE_SOCARCH_FILTER is set for this SoC.")
43 43
44 machine_socarch_suffix = d.getVar("MACHINE_SOCARCH_SUFFIX", True) 44 machine_socarch_suffix = d.getVar("MACHINE_SOCARCH_SUFFIX")
45 if not machine_socarch_suffix: 45 if not machine_socarch_suffix:
46 raise bb.parse.SkipPackage("You must set MACHINE_SOCARCH_SUFFIX as MACHINE_SOCARCH_FILTER is set for this SoC.") 46 raise bb.parse.SkipPackage("You must set MACHINE_SOCARCH_SUFFIX as MACHINE_SOCARCH_FILTER is set for this SoC.")
47 47
@@ -49,18 +49,18 @@ python __anonymous () {
49 bb.debug(1, "Use '%s' as package architecture for '%s'" % (package_arch, PN)) 49 bb.debug(1, "Use '%s' as package architecture for '%s'" % (package_arch, PN))
50 d.setVar("PACKAGE_ARCH", package_arch) 50 d.setVar("PACKAGE_ARCH", package_arch)
51 51
52 cur_package_archs = (d.getVar("PACKAGE_ARCHS", True) or "").split() 52 cur_package_archs = (d.getVar("PACKAGE_ARCHS") or "").split()
53 machine_socarch = (d.getVar("MACHINE_SOCARCH", True) or "") 53 machine_socarch = (d.getVar("MACHINE_SOCARCH") or "")
54 if not machine_socarch in cur_package_archs: 54 if not machine_socarch in cur_package_archs:
55 d.appendVar("PACKAGE_EXTRA_ARCHS", " %s" % machine_socarch) 55 d.appendVar("PACKAGE_EXTRA_ARCHS", " %s" % machine_socarch)
56 56
57 if d.getVar("TUNE_ARCH", True) == "arm": 57 if d.getVar("TUNE_ARCH") == "arm":
58 # For ARM we have two possible machine_socarch values, one for the arm and one for the thumb instruction set 58 # For ARM we have two possible machine_socarch values, one for the arm and one for the thumb instruction set
59 # add the other value to extra archs also, so that a image recipe searches both for packages. 59 # add the other value to extra archs also, so that a image recipe searches both for packages.
60 if d.getVar("ARM_INSTRUCTION_SET", True) == "thumb": 60 if d.getVar("ARM_INSTRUCTION_SET") == "thumb":
61 d.appendVar("PACKAGE_EXTRA_ARCHS", " %s" % d.getVar("ARM_EXTRA_SOCARCH", True)) 61 d.appendVar("PACKAGE_EXTRA_ARCHS", " %s" % d.getVar("ARM_EXTRA_SOCARCH"))
62 else: 62 else:
63 d.appendVar("PACKAGE_EXTRA_ARCHS", " %s" % d.getVar("THUMB_EXTRA_SOCARCH", True)) 63 d.appendVar("PACKAGE_EXTRA_ARCHS", " %s" % d.getVar("THUMB_EXTRA_SOCARCH"))
64} 64}
65 65
66MACHINE_SOCARCH = "${TUNE_PKGARCH}${MACHINE_SOCARCH_SUFFIX}" 66MACHINE_SOCARCH = "${TUNE_PKGARCH}${MACHINE_SOCARCH_SUFFIX}"
diff --git a/classes/fsl-eula-unpack.bbclass b/classes/fsl-eula-unpack.bbclass
index 198a1944..03f576e5 100644
--- a/classes/fsl-eula-unpack.bbclass
+++ b/classes/fsl-eula-unpack.bbclass
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM_append = " file://${FSL_EULA_FILE};md5=ab61cab9599935bfe9f70040
11LIC_FILES_CHKSUM[vardepsexclude] += "FSL_EULA_FILE" 11LIC_FILES_CHKSUM[vardepsexclude] += "FSL_EULA_FILE"
12 12
13python fsl_bin_do_unpack() { 13python fsl_bin_do_unpack() {
14 src_uri = (d.getVar('SRC_URI', True) or "").split() 14 src_uri = (d.getVar('SRC_URI') or "").split()
15 if len(src_uri) == 0: 15 if len(src_uri) == 0:
16 return 16 return
17 17
@@ -44,9 +44,9 @@ python fsl_bin_do_unpack() {
44} 44}
45 45
46python do_unpack() { 46python do_unpack() {
47 eula = d.getVar('ACCEPT_FSL_EULA', True) 47 eula = d.getVar('ACCEPT_FSL_EULA')
48 eula_file = d.getVar('FSL_EULA_FILE', True) 48 eula_file = d.getVar('FSL_EULA_FILE')
49 pkg = d.getVar('PN', True) 49 pkg = d.getVar('PN')
50 if eula == None: 50 if eula == None:
51 bb.fatal("To use '%s' you need to accept the Freescale EULA at '%s'. " 51 bb.fatal("To use '%s' you need to accept the Freescale EULA at '%s'. "
52 "Please read it and in case you accept it, write: " 52 "Please read it and in case you accept it, write: "
diff --git a/classes/machine-overrides-extender.bbclass b/classes/machine-overrides-extender.bbclass
index 959fdc16..4b7d66d5 100644
--- a/classes/machine-overrides-extender.bbclass
+++ b/classes/machine-overrides-extender.bbclass
@@ -15,18 +15,18 @@
15# Copyright 2016-2018 (C) O.S. Systems Software LTDA. 15# Copyright 2016-2018 (C) O.S. Systems Software LTDA.
16 16
17def machine_overrides_extender(d): 17def machine_overrides_extender(d):
18 machine_overrides = (d.getVar('PRISTINE_MACHINEOVERRIDES', True) or '').split(':') 18 machine_overrides = (d.getVar('PRISTINE_MACHINEOVERRIDES') or '').split(':')
19 19
20 # Gather the list of overrides to filter out 20 # Gather the list of overrides to filter out
21 machine_overrides_filter_out = [] 21 machine_overrides_filter_out = []
22 for override in machine_overrides: 22 for override in machine_overrides:
23 machine_overrides_filter_out += (d.getVar('MACHINEOVERRIDES_EXTENDER_FILTER_OUT_%s' % override, True) or '').split() 23 machine_overrides_filter_out += (d.getVar('MACHINEOVERRIDES_EXTENDER_FILTER_OUT_%s' % override) or '').split()
24 24
25 # Drop any overrides of filter_out prior extending 25 # Drop any overrides of filter_out prior extending
26 machine_overrides = [o for o in machine_overrides if o not in machine_overrides_filter_out] 26 machine_overrides = [o for o in machine_overrides if o not in machine_overrides_filter_out]
27 27
28 for override in machine_overrides: 28 for override in machine_overrides:
29 extender = d.getVar('MACHINEOVERRIDES_EXTENDER_%s' % override, True) 29 extender = d.getVar('MACHINEOVERRIDES_EXTENDER_%s' % override)
30 30
31 if extender: 31 if extender:
32 extender = extender.split(':') 32 extender = extender.split(':')
diff --git a/classes/qoriq_build_64bit_kernel.bbclass b/classes/qoriq_build_64bit_kernel.bbclass
index 2209e339..ffa67c8c 100644
--- a/classes/qoriq_build_64bit_kernel.bbclass
+++ b/classes/qoriq_build_64bit_kernel.bbclass
@@ -12,7 +12,7 @@ python () {
12 d.setVar('KERNEL_LD', d.getVar('CCACHE', False) + sys_multilib + '-' + 'ld.bfd' + d.getVar('HOST_LD_KERNEL_ARCH', False) + tc_options) 12 d.setVar('KERNEL_LD', d.getVar('CCACHE', False) + sys_multilib + '-' + 'ld.bfd' + d.getVar('HOST_LD_KERNEL_ARCH', False) + tc_options)
13 d.setVar('KERNEL_AR', d.getVar('CCACHE', False) + sys_multilib + '-' + 'ar' + d.getVar('HOST_AR_KERNEL_ARCH', False)) 13 d.setVar('KERNEL_AR', d.getVar('CCACHE', False) + sys_multilib + '-' + 'ar' + d.getVar('HOST_AR_KERNEL_ARCH', False))
14 14
15 error_qa = d.getVar('ERROR_QA', True) 15 error_qa = d.getVar('ERROR_QA')
16 if 'arch' in error_qa: 16 if 'arch' in error_qa:
17 d.setVar('ERROR_QA', error_qa.replace(' arch', '')) 17 d.setVar('ERROR_QA', error_qa.replace(' arch', ''))
18} 18}
diff --git a/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc b/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc
index b7171ebc..187681a8 100644
--- a/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc
+++ b/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc
@@ -2,7 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/qt4:"
2 2
3python __anonymous () { 3python __anonymous () {
4 families = ['mx6'] 4 families = ['mx6']
5 cur_families = (d.getVar('MACHINEOVERRIDES', True) or '').split(':') 5 cur_families = (d.getVar('MACHINEOVERRIDES') or '').split(':')
6 if any(map(lambda x: x in cur_families, 6 if any(map(lambda x: x in cur_families,
7 families)): 7 families)):
8 d.appendVarFlag('do_configure', 'depends', ' virtual/kernel:do_shared_workdir') 8 d.appendVarFlag('do_configure', 'depends', ' virtual/kernel:do_shared_workdir')
diff --git a/recipes-bsp/qe-ucode/qe-ucode_git.bb b/recipes-bsp/qe-ucode/qe-ucode_git.bb
index 1af630a6..9bac32d9 100644
--- a/recipes-bsp/qe-ucode/qe-ucode_git.bb
+++ b/recipes-bsp/qe-ucode/qe-ucode_git.bb
@@ -11,9 +11,9 @@ SRCREV= "57401f6dff6507055558eaa6838116baa8a2fd46"
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13python () { 13python () {
14 if not d.getVar("QE_UCODE", True): 14 if not d.getVar("QE_UCODE"):
15 PN = d.getVar("PN", True) 15 PN = d.getVar("PN")
16 FILE = os.path.basename(d.getVar("FILE", True)) 16 FILE = os.path.basename(d.getVar("FILE"))
17 bb.debug(1, "To build %s, see %s for instructions on \ 17 bb.debug(1, "To build %s, see %s for instructions on \
18 setting up your qe-ucode" % (PN, FILE)) 18 setting up your qe-ucode" % (PN, FILE))
19 raise bb.parse.SkipRecipe("because QE_UCODE is not set") 19 raise bb.parse.SkipRecipe("because QE_UCODE is not set")
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index c6bdad23..007e7d25 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
14 14
15export PYTHON = "${USRBINPATH}/python2" 15export PYTHON = "${USRBINPATH}/python2"
16 16
17M="${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}" 17M="${@d.getVar('MACHINE').replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}"
18 18
19do_install () { 19do_install () {
20 if [ ${M} = ls2088ardb ]; then 20 if [ ${M} = ls2088ardb ]; then
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb b/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
index 8438134d..f48dc81f 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
@@ -11,11 +11,11 @@ DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native"
11DEPENDS_append_qoriq-ppc = " boot-format-native" 11DEPENDS_append_qoriq-ppc = " boot-format-native"
12 12
13python () { 13python () {
14 if d.getVar("TCMODE", True) == "external-fsl": 14 if d.getVar("TCMODE") == "external-fsl":
15 return 15 return
16 16
17 ml = d.getVar("MULTILIB_VARIANTS", True) 17 ml = d.getVar("MULTILIB_VARIANTS")
18 arch = d.getVar("OVERRIDES", True) 18 arch = d.getVar("OVERRIDES")
19 19
20 if "e5500-64b:" in arch or "e6500-64b:" in arch: 20 if "e5500-64b:" in arch or "e6500-64b:" in arch:
21 if not "lib32" in ml: 21 if not "lib32" in ml:
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.1.0g.bb b/recipes-connectivity/openssl/openssl-qoriq_1.1.0g.bb
index 7a4897fd..3df7c1a3 100644
--- a/recipes-connectivity/openssl/openssl-qoriq_1.1.0g.bb
+++ b/recipes-connectivity/openssl/openssl-qoriq_1.1.0g.bb
@@ -26,7 +26,7 @@ SRCREV = "c2300d1fdb30a439f555b07f228d3bce498238d5"
26PROVIDES = "openssl" 26PROVIDES = "openssl"
27 27
28python() { 28python() {
29 pkgs = d.getVar('PACKAGES', True).split() 29 pkgs = d.getVar('PACKAGES').split()
30 for p in pkgs: 30 for p in pkgs:
31 if 'openssl-qoriq' in p: 31 if 'openssl-qoriq' in p:
32 d.appendVar("RPROVIDES_%s" % p, p.replace('openssl-qoriq', 'openssl')) 32 d.appendVar("RPROVIDES_%s" % p, p.replace('openssl-qoriq', 'openssl'))
diff --git a/recipes-daemons/ptpd/ptpd-qoriq.bb b/recipes-daemons/ptpd/ptpd-qoriq.bb
index cb047fd2..569deed5 100644
--- a/recipes-daemons/ptpd/ptpd-qoriq.bb
+++ b/recipes-daemons/ptpd/ptpd-qoriq.bb
@@ -17,7 +17,7 @@ PROVIDES = "ptpd"
17inherit autotools pkgconfig systemd 17inherit autotools pkgconfig systemd
18 18
19python() { 19python() {
20 pkgs = d.getVar('PACKAGES', True).split() 20 pkgs = d.getVar('PACKAGES').split()
21 for p in pkgs: 21 for p in pkgs:
22 if 'ptpd-qoriq' in p: 22 if 'ptpd-qoriq' in p:
23 d.appendVar("RPROVIDES_%s" % p, p.replace('ptpd-qoriq', 'ptpd')) 23 d.appendVar("RPROVIDES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
index 7423b542..889603c9 100644
--- a/recipes-devtools/qemu/qemu-qoriq_git.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -25,7 +25,7 @@ COMPATIBLE_HOST_mipsarchn64 = "null"
25PROVIDES = "qemu" 25PROVIDES = "qemu"
26 26
27python() { 27python() {
28 pkgs = d.getVar('PACKAGES', True).split() 28 pkgs = d.getVar('PACKAGES').split()
29 for p in pkgs: 29 for p in pkgs:
30 if 'qemu-qoriq' in p: 30 if 'qemu-qoriq' in p:
31 d.appendVar("RPROVIDES_%s" % p, p.replace('qemu-qoriq', 'qemu')) 31 d.appendVar("RPROVIDES_%s" % p, p.replace('qemu-qoriq', 'qemu'))
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
index 8348c1b4..b33780d2 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
@@ -82,7 +82,7 @@ PACKAGES =+ "libclc-imx libclc-imx-dev \
82 libopenvx-imx libopenvx-imx-dev \ 82 libopenvx-imx libopenvx-imx-dev \
83" 83"
84python __anonymous () { 84python __anonymous () {
85 has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT', True) or '0') 85 has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT') or '0')
86 if has_vivante_kernel_driver_support != '1': 86 if has_vivante_kernel_driver_support != '1':
87 raise bb.parse.SkipPackage('The kernel of machine needs to have Vivante kernel driver support for this recipe to be used.') 87 raise bb.parse.SkipPackage('The kernel of machine needs to have Vivante kernel driver support for this recipe to be used.')
88} 88}
@@ -102,7 +102,7 @@ SOLIBS = "${SOLIBSDEV}"
102python __anonymous() { 102python __anonymous() {
103 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have 103 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
104 # the source we cannot fix it. Disable the insane check for now. 104 # the source we cannot fix it. Disable the insane check for now.
105 packages = d.getVar('PACKAGES', True).split() 105 packages = d.getVar('PACKAGES').split()
106 for p in packages: 106 for p in packages:
107 d.appendVar("INSANE_SKIP_%s" % p, " ldflags") 107 d.appendVar("INSANE_SKIP_%s" % p, " ldflags")
108 108
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 5ead6251..8541ed7c 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -6,7 +6,7 @@ PACKAGECONFIG_remove_imxgpu3d = "gles"
6 6
7# FIXME: mesa should support 'x11-no-tls' option 7# FIXME: mesa should support 'x11-no-tls' option
8python () { 8python () {
9 overrides = d.getVar("OVERRIDES", True).split(":") 9 overrides = d.getVar("OVERRIDES").split(":")
10 if "imxgpu2d" not in overrides: 10 if "imxgpu2d" not in overrides:
11 return 11 return
12 12
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc b/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc
index 0d7249fd..ad54fc9e 100644
--- a/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc
@@ -4,7 +4,7 @@ LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5 5
6python() { 6python() {
7 pkgs = d.getVar('PACKAGES', True).split() 7 pkgs = d.getVar('PACKAGES').split()
8 for p in pkgs: 8 for p in pkgs:
9 if 'cryptodev-qoriq' in p: 9 if 'cryptodev-qoriq' in p:
10 d.appendVar("RPROVIDES_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev')) 10 d.appendVar("RPROVIDES_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb b/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb
index 60a3717e..39860c86 100644
--- a/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb
+++ b/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb
@@ -43,7 +43,7 @@ python __set_insane_skip() {
43 # Ensure we have PACKAGES expanded 43 # Ensure we have PACKAGES expanded
44 bb.build.exec_func("read_subpackage_metadata", d) 44 bb.build.exec_func("read_subpackage_metadata", d)
45 45
46 for p in d.getVar('PACKAGES', True).split(): 46 for p in d.getVar('PACKAGES').split():
47 # Even though we are packaging libraries those are plugins so we 47 # Even though we are packaging libraries those are plugins so we
48 # shouldn't rename the packages to follow its sonames. 48 # shouldn't rename the packages to follow its sonames.
49 d.setVar("DEBIAN_NOAUTONAME_%s" % p, "1") 49 d.setVar("DEBIAN_NOAUTONAME_%s" % p, "1")
@@ -66,7 +66,7 @@ python __split_libfslcodec_plugins() {
66 output_pattern='imx-codec-%s', 66 output_pattern='imx-codec-%s',
67 description='Freescale i.MX Codec (%s)', 67 description='Freescale i.MX Codec (%s)',
68 extra_depends='') 68 extra_depends='')
69 pkgs = d.getVar('PACKAGES', True).split() 69 pkgs = d.getVar('PACKAGES').split()
70 for pkg in pkgs: 70 for pkg in pkgs:
71 meta = pkg[10:] 71 meta = pkg[10:]
72 if meta != '': 72 if meta != '':
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb b/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb
index 492ab893..ed1a13da 100644
--- a/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb
+++ b/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb
@@ -30,7 +30,7 @@ python __set_insane_skip() {
30 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have 30 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
31 # the source we cannot fix it. Disable the insane check for now. 31 # the source we cannot fix it. Disable the insane check for now.
32 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those 32 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
33 for p in d.getVar('PACKAGES', True).split(): 33 for p in d.getVar('PACKAGES').split():
34 d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so textrel") 34 d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so textrel")
35} 35}
36 36