summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-07-20 09:21:20 -0300
committerGitHub <noreply@github.com>2023-07-20 09:21:20 -0300
commit9056b5e11b0057e32023c569298b9cfd4a6c7713 (patch)
treeb8359905f5547d14bbfbdf5c78fb1b9fad12ce36 /recipes-kernel
parent6c6673ed75af111782f246812e49c5f12edb8408 (diff)
parent1ec28a6c1e0a2ecead479f6cca3676ed914d9da2 (diff)
downloadmeta-freescale-9056b5e11b0057e32023c569298b9cfd4a6c7713.tar.gz
Merge pull request #1608 from MrCry0/master-imx
Update imx[-fslc] linux kernel, u-boot and related recipes to 6.1.22-2.0.0
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.1.bb16
-rw-r--r--recipes-kernel/linux/linux-imx-headers_6.1.bb4
-rw-r--r--recipes-kernel/linux/linux-imx_6.1.bb6
3 files changed, 15 insertions, 11 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.1.bb b/recipes-kernel/linux/linux-fslc-imx_6.1.bb
index 8c26da77..1dcb1f91 100644
--- a/recipes-kernel/linux/linux-fslc-imx_6.1.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_6.1.bb
@@ -28,17 +28,21 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v6.1.24 31# tag: v6.1.38
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
35# ------------------------------------------------------------------------------ 35# ------------------------------------------------------------------------------
36# tag: lf-6.1.1-1.0.0 36# tag: lf-6.1.22-2.0.0
37# 37#
38# ------------------------------------------------------------------------------ 38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s)) 39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------ 40# ------------------------------------------------------------------------------
41# - ad9ab3b3c553c ARM: imx_v7_defconfig: Remove KERNEL_LZO config 41# - 3f1f2ea729550 mxc: gpu-viv: change _QuerySignal() return type to gceSTATUS
42# - b73c6797ee427 ARM: imx_v7_defconfig: Remove KERNEL_LZO config
43# - ec33c7fc43bef touchscreen: Kconfig: add I2C dependency for CT36X
44# - 6c41233a2cfbe pwm: pwm-adp5585: fix get_state callback prototype
45# - 9c7540ecb891f pwm: pwm-rpmsg-imx: fix get_state callback prototype
42# 46#
43# NOTE to upgraders: 47# NOTE to upgraders:
44# This recipe should NOT collect individual patches, they should be applied to 48# This recipe should NOT collect individual patches, they should be applied to
@@ -48,16 +52,16 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
48 52
49require linux-imx.inc 53require linux-imx.inc
50 54
51KBRANCH = "6.1-1.0.x-imx" 55KBRANCH = "6.1-2.0.x-imx"
52SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 56SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
53SRCREV = "ad9ab3b3c553cbc3c61f233b6e2cd5abdd2a624b" 57SRCREV = "b872b1170fc8843b55e9f8838dd373ff43bb7552"
54 58
55# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 59# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
56# required by kernel-yocto.bbclass. 60# required by kernel-yocto.bbclass.
57# 61#
58# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 62# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
59# should be updated once patchlevel is merged. 63# should be updated once patchlevel is merged.
60LINUX_VERSION = "6.1.24" 64LINUX_VERSION = "6.1.38"
61 65
62KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" 66KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
63KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" 67KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"
diff --git a/recipes-kernel/linux/linux-imx-headers_6.1.bb b/recipes-kernel/linux/linux-imx-headers_6.1.bb
index cec22c1b..633418ab 100644
--- a/recipes-kernel/linux/linux-imx-headers_6.1.bb
+++ b/recipes-kernel/linux/linux-imx-headers_6.1.bb
@@ -9,8 +9,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
9 9
10SRC_URI = "git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}" 10SRC_URI = "git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
11SRCBRANCH = "lf-6.1.y" 11SRCBRANCH = "lf-6.1.y"
12LOCALVERSION = "-6.1.1-1.0.0" 12LOCALVERSION = "-6.1.22-2.0.0"
13SRCREV = "29549c7073bf72cfb2c4614d37de45ec36b60475" 13SRCREV = "66e442bc7fdcc935e6faa94c743f653263d4ed67"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
diff --git a/recipes-kernel/linux/linux-imx_6.1.bb b/recipes-kernel/linux/linux-imx_6.1.bb
index 59a7e5cc..8b1e6045 100644
--- a/recipes-kernel/linux/linux-imx_6.1.bb
+++ b/recipes-kernel/linux/linux-imx_6.1.bb
@@ -15,15 +15,15 @@ require recipes-kernel/linux/linux-imx.inc
15SRC_URI += "file://ARM-imx_v7_defconfig-Remove-KERNEL_LZO-config.patch" 15SRC_URI += "file://ARM-imx_v7_defconfig-Remove-KERNEL_LZO-config.patch"
16 16
17SRCBRANCH = "lf-6.1.y" 17SRCBRANCH = "lf-6.1.y"
18LOCALVERSION = "-6.1.1-1.0.0" 18LOCALVERSION = "-6.1.22-2.0.0"
19SRCREV = "29549c7073bf72cfb2c4614d37de45ec36b60475" 19SRCREV = "66e442bc7fdcc935e6faa94c743f653263d4ed67"
20 20
21# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 21# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
22# required by kernel-yocto.bbclass. 22# required by kernel-yocto.bbclass.
23# 23#
24# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 24# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
25# should be updated once patchlevel is merged. 25# should be updated once patchlevel is merged.
26LINUX_VERSION = "6.1.1" 26LINUX_VERSION = "6.1.22"
27 27
28KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" 28KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
29KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" 29KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"