summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@foundries.io>2023-07-19 15:20:04 +0300
committerOleksandr Suvorov <oleksandr.suvorov@foundries.io>2023-07-20 12:52:13 +0300
commit1ec28a6c1e0a2ecead479f6cca3676ed914d9da2 (patch)
treef62ceff30e02fcd55a5eebf4d70d86dd0285a4d6 /recipes-kernel
parent953c5f77eb4d6fe9847a149340dc67314cdabef9 (diff)
downloadmeta-freescale-1ec28a6c1e0a2ecead479f6cca3676ed914d9da2.tar.gz
linux-fslc-imx: Update to 6.1-2.0.x-imx
Upgrade the kernel to 6.1-2.0.x-imx based on the NXP kernel sources with the tag lf-6.1.22-2.0.0 and the mainline stable linux-6.1.y. Stable version: 6.1.38 Relevant internal commits: - 3f1f2ea729550 mxc: gpu-viv: change _QuerySignal() return type to gceSTATUS - b73c6797ee427 ARM: imx_v7_defconfig: Remove KERNEL_LZO config - ec33c7fc43bef touchscreen: Kconfig: add I2C dependency for CT36X - 6c41233a2cfbe pwm: pwm-adp5585: fix get_state callback prototype - 9c7540ecb891f pwm: pwm-rpmsg-imx: fix get_state callback prototype Remove obsolete imx6ul{l|z}-*-sdio3 dtbs as per [1]. 27548edcb4934 ("LF-8794-1 arm: dts: remove all imx6ul(l/z) btwifi-sdio3_0.dts file") Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@foundries.io>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.1.bb16
1 files changed, 10 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.1.bb b/recipes-kernel/linux/linux-fslc-imx_6.1.bb
index 8c26da77..1dcb1f91 100644
--- a/recipes-kernel/linux/linux-fslc-imx_6.1.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_6.1.bb
@@ -28,17 +28,21 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v6.1.24 31# tag: v6.1.38
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
35# ------------------------------------------------------------------------------ 35# ------------------------------------------------------------------------------
36# tag: lf-6.1.1-1.0.0 36# tag: lf-6.1.22-2.0.0
37# 37#
38# ------------------------------------------------------------------------------ 38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s)) 39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------ 40# ------------------------------------------------------------------------------
41# - ad9ab3b3c553c ARM: imx_v7_defconfig: Remove KERNEL_LZO config 41# - 3f1f2ea729550 mxc: gpu-viv: change _QuerySignal() return type to gceSTATUS
42# - b73c6797ee427 ARM: imx_v7_defconfig: Remove KERNEL_LZO config
43# - ec33c7fc43bef touchscreen: Kconfig: add I2C dependency for CT36X
44# - 6c41233a2cfbe pwm: pwm-adp5585: fix get_state callback prototype
45# - 9c7540ecb891f pwm: pwm-rpmsg-imx: fix get_state callback prototype
42# 46#
43# NOTE to upgraders: 47# NOTE to upgraders:
44# This recipe should NOT collect individual patches, they should be applied to 48# This recipe should NOT collect individual patches, they should be applied to
@@ -48,16 +52,16 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
48 52
49require linux-imx.inc 53require linux-imx.inc
50 54
51KBRANCH = "6.1-1.0.x-imx" 55KBRANCH = "6.1-2.0.x-imx"
52SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 56SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
53SRCREV = "ad9ab3b3c553cbc3c61f233b6e2cd5abdd2a624b" 57SRCREV = "b872b1170fc8843b55e9f8838dd373ff43bb7552"
54 58
55# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 59# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
56# required by kernel-yocto.bbclass. 60# required by kernel-yocto.bbclass.
57# 61#
58# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 62# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
59# should be updated once patchlevel is merged. 63# should be updated once patchlevel is merged.
60LINUX_VERSION = "6.1.24" 64LINUX_VERSION = "6.1.38"
61 65
62KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" 66KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
63KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" 67KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"