summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-01-26 17:39:29 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-01-29 16:10:03 -0600
commite55e641ab78ef33043f17942dd582652bb695034 (patch)
tree98664503f0efd4ab4351946d045c7933a9f0c728 /recipes-graphics/imx-g2d
parentbf4876581987b7e6e260b2e29a678005b34ba67d (diff)
downloadmeta-freescale-e55e641ab78ef33043f17942dd582652bb695034.tar.gz
imx-g2d-samples: New recipe for G2D sample apps
The G2D sample apps are now available as source. Note that the package is currently limited to GPU-based G2D and is not compatible with DPU-based G2D. A future release will add DPU support. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-g2d')
-rw-r--r--recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb
new file mode 100644
index 00000000..b3f1051a
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "i.MX G2D Samples"
2DESCRIPTION = "Set of sample applications for i.MX G2D"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91"
5
6# This package is currently only for GPU-based G2D. Support for DPU-based G2d is coming.
7DEPENDS = "imx-gpu-g2d"
8
9GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https"
10SRCBRANCH ?= "imx_1.0"
11SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}"
12SRCREV = "daf64d010666ef2458566573c074e238993f228c"
13
14S = "${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17
18do_install() {
19 oe_runmake install DESTDIR=${D} PREFIX=${exec_prefix}
20}
21
22FILES:${PN} += "/opt"