summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-01-26 17:35:43 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-01-29 16:10:03 -0600
commitbf4876581987b7e6e260b2e29a678005b34ba67d (patch)
tree406c057c5aea5326fbe7d120512f64e454068897 /recipes-graphics/imx-g2d
parent98b159c0a64cf4a0402a86285fb96bbab10a94cd (diff)
downloadmeta-freescale-bf4876581987b7e6e260b2e29a678005b34ba67d.tar.gz
imx-gpu-g2d: Upgrade to 6.4.3.p2.4
This version has the sample apps removed, available now in the new recipe imx-g2d-samples. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-g2d')
-rw-r--r--recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.2.bb39
-rw-r--r--recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb31
2 files changed, 31 insertions, 39 deletions
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.2.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.2.bb
deleted file mode 100644
index cc12c451..00000000
--- a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.2.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and no DPU"
7LICENSE = "Proprietary"
8LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
9
10DEPENDS += "libgal-imx"
11PROVIDES += "virtual/libg2d"
12
13FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}"
14
15SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
16SRC_URI[aarch64.md5sum] = "64559ad7909bdfe70c66e942e922b49a"
17SRC_URI[aarch64.sha256sum] = "40a5ccb7b49eecff4a8003fa74104d4cf659a6519039d3fa9d2f7548813db879"
18SRC_URI[arm.md5sum] = "3c50524afe5a19044ea8c0ce2bd9575e"
19SRC_URI[arm.sha256sum] = "9c81dfba32f2c86c92d811650e509bdf148b0181f9b3ce9a752e1210f2c78a73"
20
21S = "${WORKDIR}/${FSLBIN_NAME}"
22
23inherit fsl-eula-unpack
24
25do_install () {
26 install -d ${D}${libdir}
27 install -d ${D}${includedir}
28 cp ${S}/g2d/usr/lib/*.so* ${D}${libdir}
29 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
30 cp -r ${S}/gpu-demos/opt ${D}
31}
32
33FILES:${PN} = "${libdir}/libg2d* /opt"
34FILES:${PN}-dev = "${includedir}"
35INSANE_SKIP:${PN} = "ldflags"
36
37RDEPENDS:${PN} = "libgal-imx"
38
39COMPATIBLE_MACHINE = "(imxgpu2d)"
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb
new file mode 100644
index 00000000..8eaa0bb3
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb
@@ -0,0 +1,31 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "G2D library using i.MX GPU"
7LICENSE = "Proprietary"
8LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
9
10DEPENDS = "libgal-imx"
11PROVIDES = "virtual/libg2d"
12
13FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}"
14
15SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
16SRC_URI[aarch64.md5sum] = "9d64a9c4a870419607d9e47e832eb997"
17SRC_URI[aarch64.sha256sum] = "6065f545568e6cdc138f2d6e7cdcb525e477ce1d775c0ceabe2beb2eacf4eb5b"
18SRC_URI[arm.md5sum] = "4d6cb47f09f268533cc6a9a90cc87555"
19SRC_URI[arm.sha256sum] = "b298a38a16400e655ea46ab25b6261e602687e9970dd755594db343064a9ae53"
20
21S = "${WORKDIR}/${FSLBIN_NAME}"
22
23inherit fsl-eula-unpack
24
25do_install () {
26 cp -r -d --no-preserve=ownership ${S}/g2d/* ${D}
27}
28
29INSANE_SKIP:${PN} = "ldflags"
30
31COMPATIBLE_MACHINE = "(imxgpu2d)"