summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-01-26 16:29:32 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-01-29 16:10:03 -0600
commit98b159c0a64cf4a0402a86285fb96bbab10a94cd (patch)
treed1419b0d5f396c35d457d38ebad471605e86e236 /recipes-graphics/imx-g2d
parentd41698c912fe992d1cf43c15599f451cbaf6c1b7 (diff)
downloadmeta-freescale-98b159c0a64cf4a0402a86285fb96bbab10a94cd.tar.gz
imx-g2d: Consolidate G2D recipes in single folder
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-g2d')
-rw-r--r--recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb35
-rw-r--r--recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.2.bb39
2 files changed, 74 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb
new file mode 100644
index 00000000..c340505e
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and DPU"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
8PROVIDES += "virtual/libg2d"
9
10SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
11SRC_URI[md5sum] = "0b7fc529b3af3ecc3087a99cca0c627d"
12SRC_URI[sha256sum] = "42d470373fd72b2e2aa8d8a226e133c61b0a88e4e5bddbfec9509f7d2764f206"
13
14inherit fsl-eula-unpack
15
16do_install () {
17 install -d ${D}${libdir}
18 install -d ${D}${includedir}
19 cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
20 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
21 cp -r ${S}/gpu-demos/opt ${D}
22}
23
24FILES:${PN} = "${libdir}/libg2d* /opt"
25FILES:${PN}-dev = "${libdir}/libg2d${SOLIBSDEV} ${includedir}"
26INSANE_SKIP:${PN} += "ldflags"
27
28RDEPENDS:${PN} = "libgal-imx libdrm libopencl-imx"
29
30# This is required to provide support for VPU Amphion HEVC tile format
31# From NXP [MGS-5547] (commit e175d6b4f78deab24d319b852998bef55cdecc99):
32# VPU Amphion HEVC tile support was added using OpenCL, so add a dependency on libopencl-imx.
33RDEPENDS:${PN} += "libopencl-imx"
34
35COMPATIBLE_MACHINE = "(imxdpu)"
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.2.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.2.bb
new file mode 100644
index 00000000..cc12c451
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.2.bb
@@ -0,0 +1,39 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and no DPU"
7LICENSE = "Proprietary"
8LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
9
10DEPENDS += "libgal-imx"
11PROVIDES += "virtual/libg2d"
12
13FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}"
14
15SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
16SRC_URI[aarch64.md5sum] = "64559ad7909bdfe70c66e942e922b49a"
17SRC_URI[aarch64.sha256sum] = "40a5ccb7b49eecff4a8003fa74104d4cf659a6519039d3fa9d2f7548813db879"
18SRC_URI[arm.md5sum] = "3c50524afe5a19044ea8c0ce2bd9575e"
19SRC_URI[arm.sha256sum] = "9c81dfba32f2c86c92d811650e509bdf148b0181f9b3ce9a752e1210f2c78a73"
20
21S = "${WORKDIR}/${FSLBIN_NAME}"
22
23inherit fsl-eula-unpack
24
25do_install () {
26 install -d ${D}${libdir}
27 install -d ${D}${includedir}
28 cp ${S}/g2d/usr/lib/*.so* ${D}${libdir}
29 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
30 cp -r ${S}/gpu-demos/opt ${D}
31}
32
33FILES:${PN} = "${libdir}/libg2d* /opt"
34FILES:${PN}-dev = "${includedir}"
35INSANE_SKIP:${PN} = "ldflags"
36
37RDEPENDS:${PN} = "libgal-imx"
38
39COMPATIBLE_MACHINE = "(imxgpu2d)"