summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb
diff options
context:
space:
mode:
authorValentin Jec <valentin.jec@nxp.com>2024-10-25 13:58:18 +0300
committerValentin Jec <valentin.jec@nxp.com>2024-10-25 13:58:18 +0300
commit640880536da477a2c38e6522f4678a7b4b3819fb (patch)
tree9cbc388d05b23a248f8b3280180507e7481d0708 /recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb
parentfc287f98d9590354e2d83614ad7452608d7b7c73 (diff)
downloadmeta-freescale-640880536da477a2c38e6522f4678a7b4b3819fb.tar.gz
Upgrade NXP BSP to LF6.6.36_2.1.0
imx-g2d: Upgrade 2.1.14 -> 2.2.0 Signed-off-by: Valentin Jec <valentin.jec@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb
new file mode 100644
index 00000000..5e8f5402
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.2.0.bb
@@ -0,0 +1,47 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2024 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "G2D library using i.MX DPU"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=ca53281cc0caa7e320d4945a896fb837"
8
9DEPENDS = "libdrm ${LIBGAL_IMX}"
10LIBGAL_IMX = "libgal-imx"
11LIBGAL_IMX:mx95-nxp-bsp = ""
12
13PROVIDES += "virtual/libg2d"
14
15SRC_URI = "${FSL_MIRROR}/${IMX_BIN_NAME}.bin;fsl-eula=true;name=${IMX_SRC_URI_NAME}"
16IMX_BIN_NAME = "${BPN}-${IMX_SRC_URI_NAME}-${PV}-${IMX_SRCREV_ABBREV}"
17
18IMX_SRCREV_ABBREV = "7943590"
19IMX_SRC_URI_NAME = "v1"
20SRC_URI[v1.sha256sum] = "bf347f53e8f390a0554c0db76707819bb50cf4aaa564a9c86821ae9add26e113"
21
22IMX_SRCREV_ABBREV:mx95-nxp-bsp = "7943590"
23IMX_SRC_URI_NAME:mx95-nxp-bsp = "v2"
24SRC_URI[v2.sha256sum] = "c0a87908cd04c208659423746a57eaee6a30b4d680ec871f3495ad4a2acb5076"
25
26S = "${WORKDIR}/${IMX_BIN_NAME}"
27
28inherit fsl-eula-unpack
29
30do_install () {
31 install -d ${D}${libdir}
32 install -d ${D}${includedir}
33 cp -d ${S}/g2d/usr/lib/*.so* ${D}${libdir}
34 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
35}
36
37INSANE_SKIP:append:libc-musl = " file-rdeps"
38RDEPENDS:${PN}:append:libc-musl = " gcompat"
39
40# The packaged binaries have been stripped of debug info, so disable
41# operations accordingly.
42INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
43INHIBIT_PACKAGE_STRIP = "1"
44INHIBIT_SYSROOT_STRIP = "1"
45
46PACKAGE_ARCH = "${MACHINE_SOCARCH}"
47COMPATIBLE_MACHINE = "(imxdpu)"