summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
authorJun Zhu <junzhu@nxp.com>2023-07-19 23:29:27 +0800
committerJun Zhu <junzhu@nxp.com>2023-07-19 15:22:56 +0800
commitb94e1ad935769b399a209d5f7f9b9418d87e572c (patch)
tree71dad09daa041f5f030016730143991076e3a2e2 /recipes-dpaa2
parenta21686ea5dafdfbea37150da73572509ae6c9cd7 (diff)
downloadmeta-freescale-b94e1ad935769b399a209d5f7f9b9418d87e572c.tar.gz
management-complex: Upgrade to v10.37.0
- Add new version recipe. - Drop the old versions. Signed-off-by: Jun Zhu <junzhu@nxp.com>
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.14.1.bb41
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.20.4.bb41
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.24.0.bb41
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.29.0.bb41
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.37.0.bb (renamed from recipes-dpaa2/management-complex/management-complex_10.35.0.bb)4
5 files changed, 2 insertions, 166 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
deleted file mode 100644
index 4d4f1dcd..00000000
--- a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=afcb1213054384820390d410ab62105f"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
10SRCREV = "408110ee632f6291545b0b156cd74e7e3b4612cc"
11
12S = "${WORKDIR}/git"
13
14REGLEX:ls2088a = "ls2088a"
15REGLEX:ls2080a = "ls2080a"
16REGLEX:ls1088a = "ls1088a"
17REGLEX:lx2160a = "lx2160a"
18
19do_install () {
20 install -d ${D}/boot
21 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
22}
23
24do_deploy () {
25 install -d ${DEPLOYDIR}/mc_app
26 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
27 # make a symlink to the latest binary
28 for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
29 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
30 done
31}
32addtask deploy before do_build after do_install
33
34PACKAGES += "${PN}-image"
35FILES:${PN}-image += "/boot"
36
37INHIBIT_PACKAGE_STRIP = "1"
38
39COMPATIBLE_MACHINE = "(qoriq-arm64)"
40PACKAGE_ARCH = "${MACHINE_ARCH}"
41
diff --git a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb b/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
deleted file mode 100644
index 07f26b29..00000000
--- a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=73d4b970c18882e229e4bf1ada5bb8d6"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
10SRCREV = "f73683596a7b72124d67b62e64f3dc2bb36b9321"
11
12S = "${WORKDIR}/git"
13
14REGLEX:ls2088a = "ls2088a"
15REGLEX:ls2080a = "ls2080a"
16REGLEX:ls1088a = "ls1088a"
17REGLEX:lx2160a = "lx2160a"
18
19do_install () {
20 install -d ${D}/boot
21 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
22}
23
24do_deploy () {
25 install -d ${DEPLOYDIR}/mc_app
26 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
27 # make a symlink to the latest binary
28 for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
29 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
30 done
31}
32addtask deploy before do_build after do_install
33
34PACKAGES += "${PN}-image"
35FILES:${PN}-image += "/boot"
36
37INHIBIT_PACKAGE_STRIP = "1"
38
39COMPATIBLE_MACHINE = "(qoriq-arm64)"
40PACKAGE_ARCH = "${MACHINE_ARCH}"
41
diff --git a/recipes-dpaa2/management-complex/management-complex_10.24.0.bb b/recipes-dpaa2/management-complex/management-complex_10.24.0.bb
deleted file mode 100644
index 3408fba0..00000000
--- a/recipes-dpaa2/management-complex/management-complex_10.24.0.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=481d6288552113961a835bbabceb0c33"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
10SRCREV = "324817697a4c89a9a940fb7dba1b18909913ee20"
11
12S = "${WORKDIR}/git"
13
14REGLEX:ls2088a = "ls2088a"
15REGLEX:ls2080a = "ls2080a"
16REGLEX:ls1088a = "ls1088a"
17REGLEX:lx2160a = "lx216xa"
18REGLEX:lx2162a = "lx216xa"
19
20do_install () {
21 install -d ${D}/boot
22 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
23}
24
25do_deploy () {
26 install -d ${DEPLOYDIR}/mc_app
27 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
28 # make a symlink to the latest binary
29 for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
30 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
31 done
32}
33addtask deploy before do_build after do_install
34
35PACKAGES += "${PN}-image"
36FILES:${PN}-image += "/boot"
37
38INHIBIT_PACKAGE_STRIP = "1"
39
40COMPATIBLE_MACHINE = "(qoriq-arm64)"
41PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb b/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
deleted file mode 100644
index 08991f09..00000000
--- a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=2cb2fee5d3558ee2a81331ed121647ad"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
10SRCREV = "d21bc22000a14b0b6eeafc017fb93bc70499f74a"
11
12S = "${WORKDIR}/git"
13
14REGLEX:ls2088a = "ls2088a"
15REGLEX:ls2080a = "ls2080a"
16REGLEX:ls1088a = "ls1088a"
17REGLEX:lx2160a = "lx216xa"
18REGLEX:lx2162a = "lx216xa"
19
20do_install () {
21 install -d ${D}/boot
22 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
23}
24
25do_deploy () {
26 install -d ${DEPLOYDIR}/mc_app
27 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
28 # make a symlink to the latest binary
29 for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
30 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
31 done
32}
33addtask deploy before do_build after do_install
34
35PACKAGES += "${PN}-image"
36FILES:${PN}-image += "/boot"
37
38INHIBIT_PACKAGE_STRIP = "1"
39
40COMPATIBLE_MACHINE = "(qoriq-arm64)"
41PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-dpaa2/management-complex/management-complex_10.35.0.bb b/recipes-dpaa2/management-complex/management-complex_10.37.0.bb
index d114a92e..c683654f 100644
--- a/recipes-dpaa2/management-complex/management-complex_10.35.0.bb
+++ b/recipes-dpaa2/management-complex/management-complex_10.37.0.bb
@@ -1,13 +1,13 @@
1SUMMARY = "DPAA2 Management Complex Firmware" 1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA" 2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=1db1363924ceccb1edea921b6495bdc2" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=481d6288552113961a835bbabceb0c33"
4 4
5inherit deploy 5inherit deploy
6 6
7INHIBIT_DEFAULT_DEPS = "1" 7INHIBIT_DEFAULT_DEPS = "1"
8 8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;protocol=https;nobranch=1" 9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;protocol=https;nobranch=1"
10SRCREV = "836d7bf606b51c18b5e3726d68dcf3b3ac4de74a" 10SRCREV = "bb19f586b87b97878b4bd0d3e57da2ca40c5c69f"
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13