summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2/management-complex/management-complex_10.29.0.bb')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.29.0.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb b/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
deleted file mode 100644
index 08991f09..00000000
--- a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=2cb2fee5d3558ee2a81331ed121647ad"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
10SRCREV = "d21bc22000a14b0b6eeafc017fb93bc70499f74a"
11
12S = "${WORKDIR}/git"
13
14REGLEX:ls2088a = "ls2088a"
15REGLEX:ls2080a = "ls2080a"
16REGLEX:ls1088a = "ls1088a"
17REGLEX:lx2160a = "lx216xa"
18REGLEX:lx2162a = "lx216xa"
19
20do_install () {
21 install -d ${D}/boot
22 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
23}
24
25do_deploy () {
26 install -d ${DEPLOYDIR}/mc_app
27 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
28 # make a symlink to the latest binary
29 for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
30 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
31 done
32}
33addtask deploy before do_build after do_install
34
35PACKAGES += "${PN}-image"
36FILES:${PN}-image += "/boot"
37
38INHIBIT_PACKAGE_STRIP = "1"
39
40COMPATIBLE_MACHINE = "(qoriq-arm64)"
41PACKAGE_ARCH = "${MACHINE_ARCH}"