summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-17 14:29:17 +0000
committerAndré Draszik <andre.draszik@jci.com>2019-01-17 14:29:17 +0000
commit74df05a7f0fd698cbbe65b9bf925f186891426ca (patch)
tree169665d86e12f2aa2d6df71a856c1893267972d7 /recipes-devtools
parent9704df97f08cf5895e2f5bcfb33f1a53d10c7704 (diff)
downloadmeta-freescale-74df05a7f0fd698cbbe65b9bf925f186891426ca.tar.gz
remove True option to getVar calls
getVar() has been defaulting to expanding by default for a long time (2016), thus remove the True option from getVar() calls with a regex search and replace. Search & replace made using the following command: sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \ -i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \ | cut -d':' -f1 \ | sort -u) Signed-off-by: André Draszik <andre.draszik@jci.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
index 7423b542..889603c9 100644
--- a/recipes-devtools/qemu/qemu-qoriq_git.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -25,7 +25,7 @@ COMPATIBLE_HOST_mipsarchn64 = "null"
25PROVIDES = "qemu" 25PROVIDES = "qemu"
26 26
27python() { 27python() {
28 pkgs = d.getVar('PACKAGES', True).split() 28 pkgs = d.getVar('PACKAGES').split()
29 for p in pkgs: 29 for p in pkgs:
30 if 'qemu-qoriq' in p: 30 if 'qemu-qoriq' in p:
31 d.appendVar("RPROVIDES_%s" % p, p.replace('qemu-qoriq', 'qemu')) 31 d.appendVar("RPROVIDES_%s" % p, p.replace('qemu-qoriq', 'qemu'))