summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-06-16 16:58:01 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-12 11:41:02 -0300
commit37332a9d2cbe42f15aa371750a0eb4533fdfae9d (patch)
tree35cc5b35fbe844777fde5d8aefa7adc3c1f3c000 /recipes-devtools
parent5f20962cd0017ddd4873942abd9c8aaa3cf2a3ee (diff)
downloadmeta-freescale-37332a9d2cbe42f15aa371750a0eb4533fdfae9d.tar.gz
qemu-qoriq: upgrade to v2.4 plus fsl patches
Detailed commit log can be found at: http://git.freescale.com/git/cgit.cgi/ppc/sdk/qemu.git/log/?h=sdk-v2.0.x Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb26
1 files changed, 8 insertions, 18 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
index 99c1293d..d7651fbc 100644
--- a/recipes-devtools/qemu/qemu-qoriq_git.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -14,30 +14,19 @@ python() {
14} 14}
15 15
16DESCRIPTION = "This recipe requires poky's qemu.inc which includes the FSL \ 16DESCRIPTION = "This recipe requires poky's qemu.inc which includes the FSL \
17fixes of QorIQ ARM and QorIQ PPC targets, the recipe assumes that glx enable \ 17fixes of QorIQ ARM and QorIQ PPC targets. The recipe only works for FSL \
18config option is changed to --enable-opengl. The recipe only works for FSL \
19QorIQ machines. The poky version should be used for native/nativesdk build." 18QorIQ machines. The poky version should be used for native/nativesdk build."
20 19
21LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ 20LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
22 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" 21 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
23 22
24# This means QEMU v2.2.0 with FSL specific patches applied 23# remove not supported PACKAGECONFIG by this recipe
25PV = "2.2.0+${SRCPV}"
26
27# FIXME: this recipe requires poky's qemu.inc which assumes version 2.3
28# where glx enable config option changed to --enable-opengl. For now we
29# restore it, but we should remove the following lines when upgrading
30# to qemu 2.3:
31PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,mesa"
32# remove not supported PACKAGECONFIG by this v2.2.0 based recipe
33PACKAGECONFIG[gnutls] = ""
34PACKAGECONFIG[gcrypt] = "" 24PACKAGECONFIG[gcrypt] = ""
35PACKAGECONFIG[nettle] = "" 25PACKAGECONFIG[nettle] = ""
36PACKAGECONFIG[nss] = "" 26PACKAGECONFIG[nss] = ""
37RDEPENDS_${PN}_append = " gnutls"
38 27
39SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v1.9.x" 28SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v2.0.x"
40SRCREV = "8362a298c4feef33c84d7db2d111af18bd29ef86" 29SRCREV = "4b846e9b2b15660abace52dd27a406af08c4212d"
41 30
42# add ptest patches 31# add ptest patches
43SRC_URI_append = "\ 32SRC_URI_append = "\
@@ -49,6 +38,7 @@ S = "${WORKDIR}/git"
49 38
50QEMU_TARGETS_qoriq-ppc = "ppc" 39QEMU_TARGETS_qoriq-ppc = "ppc"
51QEMU_TARGETS_qoriq-arm = "arm" 40QEMU_TARGETS_qoriq-arm = "arm"
41QEMU_TARGETS_qoriq_arm64 = "aarch64"
52PPC_OECONF = '${SDL} --cross-prefix=${TARGET_PREFIX} --disable-werror --disable-vnc --disable-bluez --disable-curl' 42PPC_OECONF = '${SDL} --cross-prefix=${TARGET_PREFIX} --disable-werror --disable-vnc --disable-bluez --disable-curl'
53EXTRA_OECONF_e5500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}" 43EXTRA_OECONF_e5500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
54EXTRA_OECONF_e6500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}" 44EXTRA_OECONF_e6500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
@@ -56,9 +46,9 @@ EXTRA_OECONF_e6500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
56EXTRA_OECONF_e5500 = "--target-list=ppc64-softmmu ${PPC_OECONF}" 46EXTRA_OECONF_e5500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
57EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}" 47EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}"
58EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}" 48EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}"
59PACKAGECONFIG_append = " libusb" 49PACKAGECONFIG_append = " aio libusb"
60 50
61inherit pkgconfig 51DISABLE_STATIC = ""
62 52
63# Append build host pkg-config paths for native target since the host may provide sdl 53# Append build host pkg-config paths for native target since the host may provide sdl
64do_configure_prepend() { 54do_configure_prepend() {
@@ -67,7 +57,7 @@ do_configure_prepend() {
67 57
68do_configure_append () { 58do_configure_append () {
69 if ! grep 'CONFIG_FDT=y' config-host.mak; then 59 if ! grep 'CONFIG_FDT=y' config-host.mak; then
70 echo "CONFIG_RDMA=y" >> config-host.mak 60 echo "CONFIG_RDMA=y" >> config_host_mak
71 fi 61 fi
72} 62}
73 63