summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-06-30 15:09:50 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-12 11:41:02 -0300
commit5f20962cd0017ddd4873942abd9c8aaa3cf2a3ee (patch)
tree4c7cb2320850d975f4331bfd7af1cf34c5a5507d /recipes-devtools
parent47ed636e47acd5314aba4c155067a6422f9e20d2 (diff)
downloadmeta-freescale-5f20962cd0017ddd4873942abd9c8aaa3cf2a3ee.tar.gz
qemu-qoriq: Fix runtime providers
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
index d2e66c9e..99c1293d 100644
--- a/recipes-devtools/qemu/qemu-qoriq_git.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -2,7 +2,16 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3require recipes-devtools/qemu/qemu.inc 3require recipes-devtools/qemu/qemu.inc
4 4
5PROVIDES += "qemu" 5PROVIDES = "qemu"
6
7python() {
8 pkgs = d.getVar('PACKAGES', True).split()
9 for p in pkgs:
10 if 'qemu-qoriq' in p:
11 d.appendVar("RPROVIDES_%s" % p, p.replace('qemu-qoriq', 'qemu'))
12 d.appendVar("RCONFLICTS_%s" % p, p.replace('qemu-qoriq', 'qemu'))
13 d.appendVar("RREPLACES_%s" % p, p.replace('qemu-qoriq', 'qemu'))
14}
6 15
7DESCRIPTION = "This recipe requires poky's qemu.inc which includes the FSL \ 16DESCRIPTION = "This recipe requires poky's qemu.inc which includes the FSL \
8fixes of QorIQ ARM and QorIQ PPC targets, the recipe assumes that glx enable \ 17fixes of QorIQ ARM and QorIQ PPC targets, the recipe assumes that glx enable \