summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-10-25 22:44:12 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-26 14:23:37 -0300
commitbc937ade566528cc097c9321694c0f5f5ef8cbf6 (patch)
treece4a1a56a5082f9c5f6d849963f5bbef4f993733 /recipes-bsp/imx-vpu
parent700abd5d1b9ce55de5c62a8d0a82c08aa6cd6897 (diff)
downloadmeta-freescale-bc937ade566528cc097c9321694c0f5f5ef8cbf6.tar.gz
classes/use-imx-headers: Easy linux-imx-headers use
This allow to easy reuse of binary packages among similar SoCs. The usual use for this is to share SoC specific packages among different boards independently of the kernel version it is using, as far it is ABI compatible with the official version it will just work. Following recipes has been reworked to make use of the class: - imx-lib - imx-test - imx-vpu-hantro - imx-vpu - imx-alsa-plugins - gstreamer1.0-plugins-base - gstreamer1.0-plugins-imx - imx-gst1.0-plugin Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-vpu')
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb b/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb
index aebee4f0..185bb3d1 100644
--- a/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb
+++ b/recipes-bsp/imx-vpu/imx-vpu_5.4.38.bb
@@ -6,8 +6,6 @@ DESCRIPTION = "Freescale Chips&Media VPU library"
6LICENSE = "Proprietary" 6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=75abe2fa1d16ca79f87cde926f05f72d" 7LIC_FILES_CHKSUM = "file://COPYING;md5=75abe2fa1d16ca79f87cde926f05f72d"
8 8
9DEPENDS = "linux-imx-headers"
10
11PROVIDES = "virtual/imxvpu" 9PROVIDES = "virtual/imxvpu"
12 10
13PE = "1" 11PE = "1"
@@ -17,12 +15,12 @@ SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
17SRC_URI[md5sum] = "521d5f839829f8d1f2a6a0e60270243e" 15SRC_URI[md5sum] = "521d5f839829f8d1f2a6a0e60270243e"
18SRC_URI[sha256sum] = "34bed0ddf6c797f444bddfa5d5495adc751ff268b6431d8beb48129c89c9e47f" 16SRC_URI[sha256sum] = "34bed0ddf6c797f444bddfa5d5495adc751ff268b6431d8beb48129c89c9e47f"
19 17
20inherit fsl-eula-unpack 18inherit fsl-eula-unpack use-imx-headers
21 19
22PLATFORM_mx6 = "IMX6Q" 20PLATFORM_mx6 = "IMX6Q"
23 21
24do_compile () { 22do_compile () {
25 INCLUDE_DIR="-I${STAGING_INCDIR}/imx" 23 INCLUDE_DIR="-I${STAGING_INCDIR_IMX}"
26 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all 24 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all
27} 25}
28 26
@@ -30,5 +28,4 @@ do_install () {
30 oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install 28 oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install
31} 29}
32 30
33PACKAGE_ARCH = "${MACHINE_SOCARCH}"
34COMPATIBLE_MACHINE = "(mx6q|mx6dl)" 31COMPATIBLE_MACHINE = "(mx6q|mx6dl)"